summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD18
-rw-r--r--private-build-plans.toml171
-rw-r--r--private-build-plans.toml.example160
5 files changed, 180 insertions, 182 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb0988a39f5b..dd780a87adcf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ttf-iosevka-termlig-custom-git
pkgdesc = A slender monospace sans-serif and slab-serif typeface inspired by Pragmata Pro, M+ and PF DIN Mono.
- pkgver = r1145.68b55c13
+ pkgver = r1397.d5dd611b
pkgrel = 1
url = https://be5invis.github.io/Iosevka/
arch = any
@@ -13,9 +13,9 @@ pkgbase = ttf-iosevka-termlig-custom-git
depends = fontconfig
depends = xorg-font-utils
source = git+https://github.com/be5invis/Iosevka
- source = private-build-plans.toml
- md5sums = SKIP
- md5sums = 7d6b77730ff5400d69e004cc1921ea19
+ source = private-build-plans.toml.example
+ sha256sums = SKIP
+ sha256sums = 930cc4b63f9076e6cb40599ef7d51fc7fdab2eaac6a76bf344eb2d79ee4a950e
pkgname = ttf-iosevka-termlig-custom-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8bcadf271532
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!/PKGBUILD
+!/.SRCINFO
+!/.gitignore
+!/private-build-plans.toml.example
diff --git a/PKGBUILD b/PKGBUILD
index 1a8798d34c9a..9de9b2a63230 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andy Kluger <AndyKluger@gmail.com>
# Contributor: Markus Weimar <mail@markusweimar.de>
pkgname=ttf-iosevka-termlig-custom-git
-pkgver=r1145.68b55c13
+pkgver=r1397.d5dd611b
pkgrel=1
pkgdesc='A slender monospace sans-serif and slab-serif typeface inspired by Pragmata Pro, M+ and PF DIN Mono.'
arch=('any')
@@ -13,11 +13,11 @@ conflicts=()
provides=()
source=(
"git+https://github.com/be5invis/Iosevka"
- "private-build-plans.toml"
+ "private-build-plans.toml.example"
)
-md5sums=(
+sha256sums=(
'SKIP'
- '7d6b77730ff5400d69e004cc1921ea19'
+ '930cc4b63f9076e6cb40599ef7d51fc7fdab2eaac6a76bf344eb2d79ee4a950e'
)
pkgver() {
@@ -27,14 +27,18 @@ pkgver() {
prepare() {
buildplans="$HOME/.config/iosevka/private-build-plans.toml"
- [[ -f "$buildplans" ]] && cp "$buildplans" ../ || echo "$buildplans not found, using pkgbuild creator's"
- cp ../private-build-plans.toml Iosevka/
+ if [[ -f "$buildplans" ]]; then
+ cp "$buildplans" Iosevka/
+ else
+ echo ">>> $buildplans not found, using private-build-plans.toml.example"
+ cp ../private-build-plans.toml.example Iosevka/
+ fi
}
build() {
cd Iosevka
npm install
- npm run build -- ttf:iosevka-termlig-custom
+ npm run build -- ttf::iosevka-termlig-custom
}
package() {
diff --git a/private-build-plans.toml b/private-build-plans.toml
deleted file mode 100644
index df3b73ac8489..000000000000
--- a/private-build-plans.toml
+++ /dev/null
@@ -1,171 +0,0 @@
-# docs:
-# https://github.com/be5invis/Iosevka
-
-# ss## stylistic sets:
-# https://raw.githubusercontent.com/be5invis/Iosevka/master/images/stylesets.png
-
-# cv## character variants:
-# https://raw.githubusercontent.com/be5invis/Iosevka/master/images/charvars.png
-
-# ligset-* ligature sets:
-# https://raw.githubusercontent.com/be5invis/Iosevka/master/images/ligations.png
-
-[buildPlans.iosevka-custom] # Plan name
-family = "Iosevka Custom" # Font menu family name
-design = [ # Common styles
-
- "cv05", # hooky i
- "cv14", # dotted zero
- "cv24", # open double story g
- "cv26", # short leg m
- "cv27", # tailed l
- "cv46", # flat top 3
- "cv54", # open short $
-
- # "slab",
-
- # "term", # strict mono; no ligatures
- # "termlig", # strict mono; with ligatures
-
- # "ligset-haskell",
- # "ligset-idris",
- # "ligset-coq",
- # "ligset-elm",
- # "ligset-ml",
- # "ligset-fs", # F#
- # "ligset-fstar", # F*
- # "ligset-swift",
- # "ligset-purescript",
-
-]
-# upright = [] # Upright-only styles
-# italic = [] # Italic-only styles
-# oblique = [] # Oblique-only styles
-
-[buildPlans.iosevka-slab-custom] # Plan name
-family = "Iosevka Slab Custom" # Font menu family name
-design = [ # Common styles
-
- "cv05", # hooky i
- "cv14", # dotted zero
- "cv24", # open double story g
- "cv26", # short leg m
- "cv27", # tailed l
- "cv46", # flat top 3
- "cv54", # open short $
-
- "slab",
-
- # "term", # strict mono; no ligatures
- # "termlig", # strict mono; with ligatures
-
- # "ligset-haskell",
- # "ligset-idris",
- # "ligset-coq",
- # "ligset-elm",
- # "ligset-ml",
- # "ligset-fs", # F#
- # "ligset-fstar", # F*
- # "ligset-swift",
- # "ligset-purescript",
-
-]
-# upright = [] # Upright-only styles
-# italic = [] # Italic-only styles
-# oblique = [] # Oblique-only styles
-
-[buildPlans.iosevka-term-custom] # Plan name
-family = "Iosevka Term Custom" # Font menu family name
-design = [ # Common styles
-
- "cv05", # hooky i
- "cv14", # dotted zero
- "cv24", # open double story g
- "cv26", # short leg m
- "cv27", # tailed l
- "cv46", # flat top 3
- "cv54", # open short $
-
- # "slab",
-
- "term", # strict mono; no ligatures
- # "termlig", # strict mono; with ligatures
-
- # "ligset-haskell",
- # "ligset-idris",
- # "ligset-coq",
- # "ligset-elm",
- # "ligset-ml",
- # "ligset-fs", # F#
- # "ligset-fstar", # F*
- # "ligset-swift",
- # "ligset-purescript",
-
-]
-# upright = [] # Upright-only styles
-# italic = [] # Italic-only styles
-# oblique = [] # Oblique-only styles
-
-[buildPlans.iosevka-termlig-custom] # Plan name
-family = "Iosevka TermLig Custom" # Font menu family name
-design = [ # Common styles
-
- "cv05", # hooky i
- "cv14", # dotted zero
- "cv24", # open double story g
- "cv26", # short leg m
- "cv27", # tailed l
- "cv46", # flat top 3
- "cv54", # open short $
-
- # "slab",
-
- # "term", # strict mono; no ligatures
- "termlig", # strict mono; with ligatures
-
- # "ligset-haskell",
- # "ligset-idris",
- # "ligset-coq",
- # "ligset-elm",
- # "ligset-ml",
- # "ligset-fs", # F#
- # "ligset-fstar", # F*
- # "ligset-swift",
- # "ligset-purescript",
-
-]
-# upright = [] # Upright-only styles
-# italic = [] # Italic-only styles
-# oblique = [] # Oblique-only styles
-
-[buildPlans.iosevka-term-slab-custom] # Plan name
-family = "Iosevka Term Slab Custom" # Font menu family name
-design = [ # Common styles
-
- "cv05", # hooky i
- "cv14", # dotted zero
- "cv24", # open double story g
- "cv26", # short leg m
- "cv27", # tailed l
- "cv46", # flat top 3
- "cv54", # open short $
-
- "slab",
-
- "term", # strict mono; no ligatures
- # "termlig", # strict mono; with ligatures
-
- # "ligset-haskell",
- # "ligset-idris",
- # "ligset-coq",
- # "ligset-elm",
- # "ligset-ml",
- # "ligset-fs", # F#
- # "ligset-fstar", # F*
- # "ligset-swift",
- # "ligset-purescript",
-
-]
-# upright = [] # Upright-only styles
-# italic = [] # Italic-only styles
-# oblique = [] # Oblique-only styles
diff --git a/private-build-plans.toml.example b/private-build-plans.toml.example
new file mode 100644
index 000000000000..bfa075752b7d
--- /dev/null
+++ b/private-build-plans.toml.example
@@ -0,0 +1,160 @@
+# docs:
+# https://github.com/be5invis/Iosevka
+
+# ss## stylistic sets:
+# https://raw.githubusercontent.com/be5invis/Iosevka/master/images/stylesets.png
+
+# cv## character variants:
+# https://raw.githubusercontent.com/be5invis/Iosevka/master/images/charvars.png
+
+# ligset-* ligature sets:
+# https://raw.githubusercontent.com/be5invis/Iosevka/master/images/ligations.png
+
+[buildPlans.iosevka-custom] # Plan name
+family = "Iosevka Custom" # Font menu family name
+design = [ # Common styles
+
+ "cv05", # hooky i
+ "cv14", # dotted 0
+ "cv24", # open double story g
+ "cv26", # short leg m
+ "cv27", # tailed l
+ "cv33", # short @
+ "cv46", # flat top 3
+ "cv53", # tailed f
+ "cv54", # open short $
+ "cv60", # hex *
+ "cv69", # curly kK
+ "cv72", # curly vV
+ "cv74", # curly A
+ "cv76", # curly wW
+ "cv78", # curly xX
+ "cv79", # curly y
+ "cv81", # curly Y
+ "cv83", # curly R
+
+]
+# upright = [] # Upright-only styles
+# italic = [] # Italic-only styles
+# oblique = [] # Oblique-only styles
+
+[buildPlans.iosevka-slab-custom] # Plan name
+family = "Iosevka Slab Custom" # Font menu family name
+design = [ # Common styles
+
+ "slab",
+
+ "cv05", # hooky i
+ "cv14", # dotted 0
+ "cv24", # open double story g
+ "cv26", # short leg m
+ "cv27", # tailed l
+ "cv33", # short @
+ "cv46", # flat top 3
+ "cv53", # tailed f
+ "cv54", # open short $
+ "cv60", # hex *
+ "cv69", # curly kK
+ "cv72", # curly vV
+ "cv74", # curly A
+ "cv76", # curly wW
+ "cv78", # curly xX
+ "cv79", # curly y
+ "cv81", # curly Y
+ "cv83", # curly R
+
+]
+# upright = [] # Upright-only styles
+# italic = [] # Italic-only styles
+# oblique = [] # Oblique-only styles
+
+[buildPlans.iosevka-term-custom] # Plan name
+family = "Iosevka Term Custom" # Font menu family name
+design = [ # Common styles
+
+ "term", # strict mono; no ligatures
+
+ "cv05", # hooky i
+ "cv14", # dotted 0
+ "cv24", # open double story g
+ "cv26", # short leg m
+ "cv27", # tailed l
+ "cv33", # short @
+ "cv46", # flat top 3
+ "cv53", # tailed f
+ "cv54", # open short $
+ "cv60", # hex *
+ "cv69", # curly kK
+ "cv72", # curly vV
+ "cv74", # curly A
+ "cv76", # curly wW
+ "cv78", # curly xX
+ "cv79", # curly y
+ "cv81", # curly Y
+ "cv83", # curly R
+
+]
+# upright = [] # Upright-only styles
+# italic = [] # Italic-only styles
+# oblique = [] # Oblique-only styles
+
+[buildPlans.iosevka-termlig-custom] # Plan name
+family = "Iosevka TermLig Custom" # Font menu family name
+design = [ # Common styles
+
+ "termlig", # strict mono; with ligatures
+
+ "cv05", # hooky i
+ "cv14", # dotted 0
+ "cv24", # open double story g
+ "cv26", # short leg m
+ "cv27", # tailed l
+ "cv33", # short @
+ "cv46", # flat top 3
+ "cv53", # tailed f
+ "cv54", # open short $
+ "cv60", # hex *
+ "cv69", # curly kK
+ "cv72", # curly vV
+ "cv74", # curly A
+ "cv76", # curly wW
+ "cv78", # curly xX
+ "cv79", # curly y
+ "cv81", # curly Y
+ "cv83", # curly R
+
+]
+# upright = [] # Upright-only styles
+# italic = [] # Italic-only styles
+# oblique = [] # Oblique-only styles
+
+[buildPlans.iosevka-term-slab-custom] # Plan name
+family = "Iosevka Term Slab Custom" # Font menu family name
+design = [ # Common styles
+
+ "term", # strict mono; no ligatures
+ "slab",
+
+ "cv05", # hooky i
+ "cv14", # dotted 0
+ "cv24", # open double story g
+ "cv26", # short leg m
+ "cv27", # tailed l
+ "cv33", # short @
+ "cv46", # flat top 3
+ "cv53", # tailed f
+ "cv54", # open short $
+ "cv60", # hex *
+ "cv69", # curly kK
+ "cv72", # curly vV
+ "cv74", # curly A
+ "cv76", # curly wW
+ "cv78", # curly xX
+ "cv79", # curly y
+ "cv81", # curly Y
+ "cv83", # curly R
+
+]
+# upright = [] # Upright-only styles
+# italic = [] # Italic-only styles
+# oblique = [] # Oblique-only styles