summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD29
2 files changed, 27 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a192d8748536..cc1bb4ca3980 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,19 @@
+# Generated by mksrcinfo v8
+# Wed Jan 18 23:05:12 UTC 2017
pkgbase = ttf-mac-fonts
pkgdesc = Mac fonts including Lucida Grande, Apple Garamond and other fonts from Apple
- pkgver = 1
- pkgrel = 7
+ pkgver = 20100901.134
+ pkgrel = 1
url = http://www.apple.com/safari/
install = ttf-mac-fonts.install
arch = any
license = custom
makedepends = subversion
- makedepends = wget
conflicts = macfonts
+ source = ttf-mac-fonts::svn+https://svn.code.sf.net/p/macbuntu/code/Macbuntu/fonts/
+ source = http://images.apple.com/legal/sla/docs/SafariWindows.pdf
+ md5sums = SKIP
+ md5sums = 4886e440aac9586dd03445c76a2ccef1
pkgname = ttf-mac-fonts
diff --git a/PKGBUILD b/PKGBUILD
index 2823e479fcc2..662360224cef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,29 +4,38 @@
#Contributor: Shanto (at hotmail.com)
#Contributor: Erus <erus.iluvatar@gmail.com>
pkgname=ttf-mac-fonts
-pkgver=1
-pkgrel=7
+pkgver=20100901.134
+pkgrel=1
pkgdesc="Mac fonts including Lucida Grande, Apple Garamond and other fonts from Apple"
arch=('any')
url="http://www.apple.com/safari/"
license=('custom')
depends=()
-makedepends=('subversion' 'wget')
+makedepends=('subversion')
conflicts=('macfonts')
-source=()
-md5sums=()
+source=(
+ "${pkgname}::svn+https://svn.code.sf.net/p/macbuntu/code/Macbuntu/fonts/"
+ 'http://images.apple.com/legal/sla/docs/SafariWindows.pdf'
+)
+md5sums=(
+ 'SKIP'
+ '4886e440aac9586dd03445c76a2ccef1'
+)
install='ttf-mac-fonts.install'
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ svn info | awk '/Revision/{r=$2}/Date/{gsub(/-/,"");d=$4}END{print d"."r}'
+}
+
package() {
- cd $srcdir
- find -delete
- svn co --force https://svn.code.sf.net/p/macbuntu/code/Macbuntu/fonts/ ./
+ cd $srcdir/${pkgname}
+ pwd
install -d $pkgdir/usr/share/fonts/{TTF,Type1}
install -m644 gbk/*.ttf $pkgdir/usr/share/fonts/TTF
install -m644 mac/*.ttf $pkgdir/usr/share/fonts/TTF
install -m644 mac/*.pfb $pkgdir/usr/share/fonts/Type1
- wget http://images.apple.com/legal/sla/docs/SafariWindows.pdf
install -d $pkgdir/usr/share/licenses/$pkgname
- install -m644 SafariWindows.pdf $pkgdir/usr/share/licenses/$pkgname/
+ install -m644 $srcdir/SafariWindows.pdf $pkgdir/usr/share/licenses/$pkgname/
}