summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0bb1616d90ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ttf-myuppy-gb
+ pkgdesc = MYuppy GB is a free Simplified Chinese font from the Symbian project, designed to appeal to young urban professionals.
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/SymbianSource/oss.FCL.sf.os.textandloc/tree/master/fontservices/referencefonts/truetype
+ arch = any
+ license = EPL
+ source = https://raw.githubusercontent.com/SymbianSource/oss.FCL.sf.os.textandloc/master/fontservices/referencefonts/truetype/MYuppyGB-Medium.ttf
+ source = https://raw.githubusercontent.com/SymbianSource/oss.FCL.sf.os.textandloc/master/fontservices/referencefonts/truetype/MYuppyGB-Medium_README.TXT
+ sha256sums = a5b6d8ab3d098796ef93178b5a384419738f3ac573b6943b2dc11500347be973
+ sha256sums = f7c2c3b012e870077ef159890f614f83bb430bfd7dde0a77d978ea1e6a677236
+
+pkgname = ttf-myuppy-gb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0af12328173a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: oldherl <oldherl@gmail.com>
+
+pkgname=ttf-myuppy-gb
+pkgver=1
+pkgrel=1
+pkgdesc="MYuppy GB is a free Simplified Chinese font from the Symbian project, designed to appeal to young urban professionals."
+url="https://github.com/SymbianSource/oss.FCL.sf.os.textandloc/tree/master/fontservices/referencefonts/truetype"
+license=("EPL")
+arch=(any)
+source=(
+"https://raw.githubusercontent.com/SymbianSource/oss.FCL.sf.os.textandloc/master/fontservices/referencefonts/truetype/MYuppyGB-Medium.ttf"
+"https://raw.githubusercontent.com/SymbianSource/oss.FCL.sf.os.textandloc/master/fontservices/referencefonts/truetype/MYuppyGB-Medium_README.TXT"
+)
+sha256sums=('a5b6d8ab3d098796ef93178b5a384419738f3ac573b6943b2dc11500347be973'
+ 'f7c2c3b012e870077ef159890f614f83bb430bfd7dde0a77d978ea1e6a677236')
+
+prepare(){
+ iconv -f windows-1252 -t utf-8 MYuppyGB-Medium_README.TXT > README
+}
+
+package(){
+ install -d "$pkgdir/usr/share/fonts/TTF"
+ install -d "$pkgdir/usr/share/doc/${pkgname}"
+ install -m644 MYuppyGB-Medium.ttf "$pkgdir/usr/share/fonts/TTF/"
+ install -m644 README "$pkgdir/usr/share/doc/${pkgname}/"
+}