aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD24
2 files changed, 31 insertions, 14 deletions
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..f2b059cd8eeb
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2015 The Things Network
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
index 9228dbf658bd..73780866863b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,25 +8,21 @@ arch=(x86_64)
url="https://github.com/TheThingsNetwork/ttn/tree/master/ttnctl"
license=('MIT')
provides=("$pkgname" "$pkgname-linux-amd64")
-source=("https://ttnreleases.blob.core.windows.net/release/master/$pkgname-linux-amd64.tar.gz")
-md5sums=("0d5d946317d93bddb5b0860cd8793030")
+source=(
+ "https://ttnreleases.blob.core.windows.net/release/master/$pkgname-linux-amd64.tar.gz"
+ "https://github.com/TheThingsNetwork/ttn/raw/develop/LICENSE"
+)
+md5sums=(
+ "0d5d946317d93bddb5b0860cd8793030"
+ "a77e15a2ad23e13f5a142493ad0c73b7"
+)
pkgver() {
# didn't get it in one sed expression
$srcdir/ttnctl-linux-amd64 version | grep Version | sed -E 's/.*Version.*=v(.*)[[:blank:]]?.*/\1/g' | sed 's/-dev/dev/'
}
-prepare() {
- wget "https://github.com/TheThingsNetwork/ttn/raw/develop/LICENSE" -O $srcdir/LICENSE
-}
-
-build() {
- echo "foo"
-}
-
package() {
- install -d "$pkgdir/usr/bin/"
- mv "$srcdir/$pkgname-linux-amd64" $pkgdir/usr/bin/ttnctl
- install -d "$pkgdir/usr/share/licenses/$pkgname"
- mv "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm755 $pkgname-linux-amd64 $pkgdir/usr/bin/ttnctl
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}