summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 79c05e303c4e..643b82d86d69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tumbler-git
pkgdesc = D-Bus service for applications to request thumbnails (git checkout)
- pkgver = 4.17.0+1+gb38db8a
+ pkgver = 4.19.0+1+g704de37
pkgrel = 1
url = https://docs.xfce.org/xfce/tumbler/start
arch = i686
@@ -9,6 +9,7 @@ pkgbase = tumbler-git
arch = armv7h
groups = xfce4-git
license = GPL2
+ license = LGPL
makedepends = ffmpegthumbnailer
makedepends = freetype2
makedepends = libgsf
@@ -18,14 +19,14 @@ pkgbase = tumbler-git
makedepends = xfce4-dev-tools
makedepends = git
depends = gdk-pixbuf2
- depends = libxfce4util>=4.17.1
+ depends = libxfce4util
optdepends = ffmpegthumbnailer: for video thumbnails
optdepends = poppler-glib: for PDF thumbnails
optdepends = libgsf: for ODF thumbnails
optdepends = libopenraw: for RAW thumbnails
optdepends = freetype2: for font thumbnails
optdepends = libgepub: for epub thumbnails
- provides = tumbler=4.17.0
+ provides = tumbler=4.19.0
conflicts = tumbler
source = tumbler::git+https://gitlab.xfce.org/xfce/tumbler.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index d2505ee4cbed..98cfa3648239 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
_pkgname=tumbler
pkgname=${_pkgname}-git
-pkgver=4.17.0+1+gb38db8a
+pkgver=4.19.0+1+g704de37
pkgrel=1
pkgdesc="D-Bus service for applications to request thumbnails (git checkout)"
arch=('i686' 'x86_64' 'aarch64' 'armv7h')
url="https://docs.xfce.org/xfce/tumbler/start"
-license=(GPL2)
+license=('GPL2' 'LGPL')
groups=('xfce4-git')
-depends=('gdk-pixbuf2' 'libxfce4util>=4.17.1')
+depends=('gdk-pixbuf2' 'libxfce4util')
makedepends=('ffmpegthumbnailer' 'freetype2' 'libgsf' 'libopenraw' 'poppler-glib'
'libgepub' 'xfce4-dev-tools' 'git')
optdepends=('ffmpegthumbnailer: for video thumbnails'
@@ -22,7 +22,7 @@ optdepends=('ffmpegthumbnailer: for video thumbnails'
'libgepub: for epub thumbnails')
provides=("${_pkgname}=${pkgver%%+*}")
conflicts=("${_pkgname}")
-source=(${_pkgname}::git+https://gitlab.xfce.org/xfce/tumbler.git)
+source=("${_pkgname}"::git+https://gitlab.xfce.org/xfce/tumbler.git)
sha256sums=('SKIP')
pkgver() {
@@ -35,9 +35,8 @@ build() {
./autogen.sh \
--prefix=/usr \
--sysconfdir=/etc \
- --libexecdir=/usr/lib/xfce4 \
- --disable-static \
- --disable-debug
+ --disable-debug \
+ --disable-gstreamer-thumbnailer
make
}