summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD36
-rw-r--r--vncserver.service29
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b67df3c473b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = turbovnc
+ pkgdesc = An optimized version of TightVNC
+ pkgver = 1.2.3
+ pkgrel = 1
+ url = http://www.turbovnc.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = libjpeg-turbo
+ makedepends = cmake
+ makedepends = rsync
+ depends = libxaw
+ depends = libxt
+ depends = libxcursor
+ conflicts = turbovnc-bin
+ conflicts = tigervnc
+ conflicts = tigervnc-svn
+ conflicts = tightvnc
+ replaces = turbovnc-bin
+ source = turbovnc-1.2.3.tar.gz::http://sourceforge.net/projects/turbovnc/files/1.2.3/turbovnc-1.2.3.tar.gz/download
+ source = vncserver.service
+ sha256sums = 44d19ea293a72d097733251d70adfe020da245cc84ff121e4232e0cd30a1a368
+ sha256sums = ccadf1fc708fad601e6113464d6c533a629f6dc9116f6071347cd0b465c1f48b
+
+pkgname = turbovnc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d45fb043448
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: kfgz <kfgz at interia pl>
+# Contributor: Kaspar Bumke <kaspar dot bumke at gmail dot com>
+# Contributor: maleadt <tim dot besard at gmail dot com>
+
+pkgname="turbovnc"
+pkgdesc="An optimized version of TightVNC"
+pkgver=1.2.3
+pkgrel=1
+arch=('i686' 'x86_64')
+url="http://www.turbovnc.org/"
+license=('GPL')
+makedepends=('libjpeg-turbo' 'cmake' 'rsync')
+depends=('libxaw' 'libxt' 'libxcursor')
+sha256sums=('44d19ea293a72d097733251d70adfe020da245cc84ff121e4232e0cd30a1a368'
+ 'ccadf1fc708fad601e6113464d6c533a629f6dc9116f6071347cd0b465c1f48b')
+conflicts=('turbovnc-bin' 'tigervnc' 'tigervnc-svn' 'tightvnc')
+replaces=('turbovnc-bin')
+source=(${pkgname}-${pkgver}.tar.gz::http://sourceforge.net/projects/${pkgname}/files/${pkgver}/${pkgname}-${pkgver}.tar.gz/download
+ vncserver.service)
+
+build() {
+ mkdir "${srcdir}"/${pkgname}-${pkgver}/build
+ cd "${srcdir}"/${pkgname}-${pkgver}/build
+ cmake -G "Unix Makefiles" -DTJPEG_LIBRARY=/usr/lib/libturbojpeg.so -DCMAKE_INSTALL_PREFIX=/usr -DTVNC_DOCDIR=/usr/share/doc/${pkgname} ../
+ make
+}
+
+package() {
+ cd "${srcdir}"/${pkgname}-${pkgver}/build
+ make DESTDIR="${pkgdir}" install
+ mv "${pkgdir}"/usr/README.txt "${pkgdir}"/usr/share/doc/turbovnc/README.txt
+ install -dm755 "${pkgdir}"/etc
+ mv "${pkgdir}"/usr/etc "${pkgdir}"/
+ rm -r "${pkgdir}"/etc/init.d
+ install -D -m644 "${srcdir}"/vncserver.service "${pkgdir}"/usr/lib/systemd/system/vncserver.service
+}
diff --git a/vncserver.service b/vncserver.service
new file mode 100644
index 000000000000..b64e729a6c86
--- /dev/null
+++ b/vncserver.service
@@ -0,0 +1,29 @@
+# The vncserver service unit file
+#
+# 1. Copy this file to /etc/systemd/system/vncserver@:<display>.service
+# 2. Edit User=
+# ("User=foo")
+# 3. Edit and vncserver parameters appropriately
+# ("/usr/bin/vncserver %i -arg1 -arg2 -argn")
+# 4. Run `systemctl --system daemon-reload`
+# 5. Run `systemctl enable vncserver@:<display>.service`
+#
+# DO NOT RUN THIS SERVICE if your local area network is untrusted!
+#
+# See the wiki page for more on security
+# https://wiki.archlinux.org/index.php/Vncserver
+
+[Unit]
+Description=Remote desktop service (VNC)
+After=syslog.target network.target
+
+[Service]
+Type=forking
+User=
+# Clean any existing files in /tmp/.X11-unix environment, especially useful for VMs
+ExecStartPre=-/usr/bin/vncserver -kill %i
+ExecStart=/usr/bin/vncserver %i
+ExecStop=/usr/bin/vncserver -kill %i
+
+[Install]
+WantedBy=multi-user.target