summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 15 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab55ef335a99..e27dd6f85102 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,10 +12,14 @@ pkgbase = turpial-git
depends = libturpial-git
depends = notification-daemon
depends = python2-babel
- depends = python2-jinja
depends = python2-notify
- depends = python2-pyqt4
depends = python2-simplejson
+ optdepends = pygtk>=2.12: GTK user interface
+ optdepends = aspell: GTK user interface
+ optdepends = gnome-spell: GTK user interface
+ optdepends = python2-gtkspell>=2.25.3: GTK user interface
+ optdepends = python2-pyqt4>=2.12: Qt user interface
+ optdepends = python2-jinja>=2.6: Qt user interface
provides = turpial=3.0.r1647.2c44359
conflicts = turpial
source = turpial-git::git://github.com/satanas/Turpial.git#branch=development
diff --git a/PKGBUILD b/PKGBUILD
index 2e72c89d1f5d..323ad27e6338 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,15 @@ pkgdesc="A multi-interface Twitter client written in Python"
arch=(any)
url=http://turpial.org.ve/
license=(GPL3)
-depends=(gstreamer0.10-python hspell libturpial-git notification-daemon python2-babel python2-jinja
- python2-notify python2-pyqt4 python2-simplejson)
+depends=('gstreamer0.10-python' 'hspell' 'libturpial-git' 'notification-daemon' 'python2-babel' 'python2-notify' 'python2-simplejson')
+optdepends=(
+ 'pygtk>=2.12: GTK user interface'
+ 'aspell: GTK user interface'
+ 'gnome-spell: GTK user interface'
+ 'python2-gtkspell>=2.25.3: GTK user interface'
+ 'python2-pyqt4>=2.12: Qt user interface'
+ 'python2-jinja>=2.6: Qt user interface'
+)
makedepends=(git python2-setuptools)
provides=(${pkgname%-*}=$pkgver)
conflicts=(${pkgname%-*})