summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD44
-rwxr-xr-xtuxedo-wmi.install12
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..996e3b55e827
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = tuxedo-wmi
+ pkgdesc = A reverse engineering driver for the Clevo P15SM/P17SM/P150SM/P157SM/P170SM/P177SM backlight keyboard, by Christoph Jaeger
+ pkgver = 1.5.1
+ pkgrel = 2
+ url = http://www.linux-onlineshop.de/forum/index.php?page=Thread&threadID=26&s=82130b57e71bd5b6ea569abc1424025c6f8d412d
+ install = tuxedo-wmi.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = linux-headers
+ conflicts = clevo_wmi-git
+ conflicts = clevo-wmi-dkms
+ conflicts = clevo-wmi
+ conflicts = clevo-wmi-dkms
+ conflicts = tuxedo-wmi-dkms
+ replaces = clevo-wmi
+ source = tuxedo-wmi-1.5.1.src.tar.gz::http://www.linux-onlineshop.de/forum/index.php?page=Attachment&attachmentID=424&h=3df4c21145314ceaeadd7986662b2a5b01d1094f&s=5196669c65535d86e616f839936c42a5166a40a0
+ md5sums = c5bf0f815f394baf4fabe2c78d9483cc
+
+pkgname = tuxedo-wmi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..f602e31f8e0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Author: Christoph Jaeger <christophjaeger AT linux DOT com>
+# Maintainer: Marc Rozanc <marc AT rozanc DOT fr>
+
+pkgname="tuxedo-wmi"
+pkgver="1.5.1"
+pkgrel=2
+pkgdesc='A reverse engineering driver for the Clevo P15SM/P17SM/P150SM/P157SM/P170SM/P177SM backlight keyboard, by Christoph Jaeger'
+arch=('i686' 'x86_64')
+license=('GPL')
+url='http://www.linux-onlineshop.de/forum/index.php?page=Thread&threadID=26&s=82130b57e71bd5b6ea569abc1424025c6f8d412d'
+makedepends=('linux-headers')
+replaces=("clevo-wmi")
+conflicts=("clevo_wmi-git" "clevo-wmi-dkms" "clevo-wmi" "clevo-wmi-dkms" "tuxedo-wmi-dkms")
+source=("tuxedo-wmi-${pkgver}.src.tar.gz::http://www.linux-onlineshop.de/forum/index.php?page=Attachment&attachmentID=424&h=3df4c21145314ceaeadd7986662b2a5b01d1094f&s=5196669c65535d86e616f839936c42a5166a40a0")
+md5sums=('c5bf0f815f394baf4fabe2c78d9483cc')
+install='tuxedo-wmi.install'
+
+build() {
+ cd "${srcdir}/tuxedo-wmi-${pkgver}/src"
+ make
+}
+
+package() {
+ cd "${srcdir}/tuxedo-wmi-${pkgver}/src"
+
+ _PACKAGES=`pacman -Qsq linux`
+ _KERNELS=`pacman -Ql $_packages | grep /modules.alias.bin | sed 's/.*\/lib\/modules\/\(.*\)\/modules.alias.bin/\1/g'`
+
+ # Find all extramodules directories
+ _EXTRAMODULES=`find /usr/lib/modules -name version | sed 's|\/usr\/lib\/modules\/||; s|\/version||'`
+
+ # Loop through all detected kernels
+ for _kernver in $_KERNELS; do
+ # Loop through all detected extramodules directories
+ for _moduledirs in $_EXTRAMODULES; do
+ # Check which extramodules directory corresponds with the built module
+ if [ `cat "/usr/lib/modules/${_moduledirs}/version"` = $_kernver ]; then
+ mkdir -p "${pkgdir}/usr/lib/modules/${_moduledirs}/"
+ install -m644 tuxedo-wmi.ko "${pkgdir}/usr/lib/modules/${_moduledirs}/"
+ gzip "${pkgdir}/usr/lib/modules/${_moduledirs}/tuxedo-wmi.ko"
+ fi
+ done
+ done
+}
diff --git a/tuxedo-wmi.install b/tuxedo-wmi.install
new file mode 100755
index 000000000000..122d72497404
--- /dev/null
+++ b/tuxedo-wmi.install
@@ -0,0 +1,12 @@
+post_install() {
+ depmod -a
+}
+
+post_upgrade() {
+ depmod -a
+}
+
+post_remove() {
+ depmod -a
+}
+