summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD74
-rw-r--r--nogcj.patch168
-rw-r--r--tuxguitar.desktop13
-rw-r--r--tuxguitar.xml19
5 files changed, 304 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cfac745a0cff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = tuxguitar
+ pkgdesc = multitrack guitar tablature editor and player
+ pkgver = 1.4
+ pkgrel = 2
+ url = http://sourceforge.net/projects/tuxguitar
+ arch = x86_64
+ license = LGPL
+ makedepends = unzip
+ makedepends = zip
+ makedepends = apache-ant
+ makedepends = jack
+ makedepends = fluidsynth
+ makedepends = jdk8-openjdk
+ makedepends = maven
+ depends = java-runtime>=8
+ depends = alsa-lib
+ depends = gtk2
+ depends = libxtst
+ optdepends = fluidsynth
+ source = tuxguitar-src-1.4.tar.gz::http://downloads.sourceforge.net/project/tuxguitar/TuxGuitar/TuxGuitar-1.4/tuxguitar-1.4-src.tar.gz
+ source = tuxguitar.desktop
+ source = tuxguitar.xml
+ source = nogcj.patch
+ sha256sums = ac72690bc1c20919dd66df46f757c6890be4c54b38f2a3b59a0265c777392210
+ sha256sums = 6a6c2c64f75f7402b6913e493b847f6b6d9d789bad7ab3ec023f61784d38bbfa
+ sha256sums = d5b79049776c39e8c58bfa5b9748678ed2ed376e7c4cc1e837de5666f18a8e56
+ sha256sums = bda4bc1b864ecfa27392a145854ee3b5ab20876c2d2bc38bbf85f92ce97fe2bc
+
+pkgname = tuxguitar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df2cf84651ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Contributor: |AhIoRoS| < ahioros@gmail.com >
+
+pkgname=tuxguitar
+pkgver=1.4
+pkgrel=2
+pkgdesc="multitrack guitar tablature editor and player"
+arch=('x86_64')
+url="http://sourceforge.net/projects/tuxguitar"
+license=('LGPL')
+depends=('java-runtime>=8' 'alsa-lib' 'gtk2' 'libxtst')
+makedepends=('unzip' 'zip' 'apache-ant' 'jack' 'fluidsynth' 'jdk8-openjdk' 'maven')
+optdepends=('fluidsynth')
+source=(tuxguitar-src-$pkgver.tar.gz::http://downloads.sourceforge.net/project/tuxguitar/TuxGuitar/TuxGuitar-$pkgver/tuxguitar-$pkgver-src.tar.gz
+ tuxguitar.desktop tuxguitar.xml nogcj.patch)
+sha256sums=('ac72690bc1c20919dd66df46f757c6890be4c54b38f2a3b59a0265c777392210'
+ '6a6c2c64f75f7402b6913e493b847f6b6d9d789bad7ab3ec023f61784d38bbfa'
+ 'd5b79049776c39e8c58bfa5b9748678ed2ed376e7c4cc1e837de5666f18a8e56'
+ 'bda4bc1b864ecfa27392a145854ee3b5ab20876c2d2bc38bbf85f92ce97fe2bc')
+
+case $CARCH in
+ i686) _arch=x86;;
+ *) _arch=$CARCH;;
+esac
+
+prepare() {
+ cd tuxguitar-$pkgver-src
+ patch -Np1 -i ../nogcj.patch
+}
+
+build() {
+ export MAVEN_OPTS="$MAVEN_OPTS -Duser.home=$srcdir"
+ export JAVA_HOME="/usr/lib/jvm/java-8-openjdk"
+
+ cd tuxguitar-$pkgver-src
+ for _i in . TuxGuitar-{lib,gm-utils} \
+ build-scripts/{tuxguitar,native-modules/tuxguitar-{alsa,oss,jack,fluidsynth}}-linux-$_arch
+ do (
+ cd $_i
+ mvn install
+ ); done
+}
+
+package() {
+ # tuxguitar
+ cd tuxguitar-$pkgver-src/build-scripts
+ install -d "$pkgdir"/usr/share
+ cp -a tuxguitar-linux-$_arch/target/tuxguitar-$pkgver-linux-$_arch "$pkgdir"/usr/share/tuxguitar
+ cp -a native-modules/tuxguitar-{alsa,oss,jack,fluidsynth}-linux-$_arch/target/build/* \
+ "$pkgdir"/usr/share/tuxguitar/
+
+ # icons
+ cd ..
+ for _i in 16 24 32 48 64 96; do
+ _dir="$pkgdir"/usr/share/icons/hicolor/${_i}x${_i}
+ install -d "$_dir"/{apps,mimetypes}
+ install -m644 TuxGuitar/share/skins/Lavender/icon-${_i}x${_i}.png "$_dir"/apps/tuxguitar.png
+ for _m in audio-x-{tuxguitar,gtp,ptb}; do
+ ln -sr "$_dir"/apps/tuxguitar.png "$_dir"/mimetypes/$_m.png
+ done
+ done
+
+ # desktop files
+ cd ..
+ install -D /dev/stdin "$pkgdir"/usr/bin/tuxguitar <<EOF
+#!/bin/sh -e
+export SWT_GTK3=0
+cd /usr/share/tuxguitar
+exec ./tuxguitar.sh -Dorg.eclipse.swt.internal.gtk.cairoGraphics=false "\$@"
+EOF
+ install -Dm644 tuxguitar.xml "$pkgdir"/usr/share/mime/packages/tuxguitar.xml
+ install -Dm644 tuxguitar.desktop "$pkgdir"/usr/share/applications/tuxguitar.desktop
+}
diff --git a/nogcj.patch b/nogcj.patch
new file mode 100644
index 000000000000..d312cb81ae7f
--- /dev/null
+++ b/nogcj.patch
@@ -0,0 +1,168 @@
+diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-alsa-linux-armv7hl/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-alsa-linux-armv7hl/pom.xml
+--- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-alsa-linux-armv7hl/pom.xml 2016-12-22 21:04:26.000000000 +0100
++++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-alsa-linux-armv7hl/pom.xml 2017-02-08 22:06:28.220720753 +0100
+@@ -22,8 +22,8 @@
+
+ <tuxguitar-alsa.jni.path>${parent.relativePath}/TuxGuitar-alsa/jni/</tuxguitar-alsa.jni.path>
+ <tuxguitar-alsa.jni.cc>${tuxguitar.jni.cc}</tuxguitar-alsa.jni.cc>
+- <tuxguitar-alsa.jni.cflags>-I$(shell gcj -print-file-name=include/) -fPIC</tuxguitar-alsa.jni.cflags>
+- <tuxguitar-alsa.jni.ldflags>-fPIC</tuxguitar-alsa.jni.ldflags>
++ <tuxguitar-alsa.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -fPIC</tuxguitar-alsa.jni.cflags>
++ <tuxguitar-alsa.jni.ldflags>${LDFLAGS} -fPIC</tuxguitar-alsa.jni.ldflags>
+ <tuxguitar-alsa.jni.ldlibs>-lasound</tuxguitar-alsa.jni.ldlibs>
+ <tuxguitar-alsa.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-alsa.jni.ldpath>
+ <tuxguitar-alsa.jni.library.name>tuxguitar-alsa-jni</tuxguitar-alsa.jni.library.name>
+diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-alsa-linux-x86/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-alsa-linux-x86/pom.xml
+--- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-alsa-linux-x86/pom.xml 2016-12-22 21:04:26.000000000 +0100
++++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-alsa-linux-x86/pom.xml 2017-02-08 22:06:28.220720753 +0100
+@@ -22,8 +22,8 @@
+
+ <tuxguitar-alsa.jni.path>${parent.relativePath}/TuxGuitar-alsa/jni/</tuxguitar-alsa.jni.path>
+ <tuxguitar-alsa.jni.cc>${tuxguitar.jni.cc}</tuxguitar-alsa.jni.cc>
+- <tuxguitar-alsa.jni.cflags>-I$(shell gcj -print-file-name=include/) -m32 -fPIC</tuxguitar-alsa.jni.cflags>
+- <tuxguitar-alsa.jni.ldflags>-m32 -fPIC</tuxguitar-alsa.jni.ldflags>
++ <tuxguitar-alsa.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -m32 -fPIC</tuxguitar-alsa.jni.cflags>
++ <tuxguitar-alsa.jni.ldflags>${LDFLAGS} -m32 -fPIC</tuxguitar-alsa.jni.ldflags>
+ <tuxguitar-alsa.jni.ldlibs>-lasound</tuxguitar-alsa.jni.ldlibs>
+ <tuxguitar-alsa.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-alsa.jni.ldpath>
+ <tuxguitar-alsa.jni.library.name>tuxguitar-alsa-jni</tuxguitar-alsa.jni.library.name>
+diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-alsa-linux-x86_64/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-alsa-linux-x86_64/pom.xml
+--- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-alsa-linux-x86_64/pom.xml 2016-12-22 21:04:26.000000000 +0100
++++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-alsa-linux-x86_64/pom.xml 2017-02-08 22:06:28.220720753 +0100
+@@ -22,8 +22,8 @@
+
+ <tuxguitar-alsa.jni.path>${parent.relativePath}/TuxGuitar-alsa/jni/</tuxguitar-alsa.jni.path>
+ <tuxguitar-alsa.jni.cc>${tuxguitar.jni.cc}</tuxguitar-alsa.jni.cc>
+- <tuxguitar-alsa.jni.cflags>-I$(shell gcj -print-file-name=include/) -m64 -fPIC</tuxguitar-alsa.jni.cflags>
+- <tuxguitar-alsa.jni.ldflags>-m64 -fPIC</tuxguitar-alsa.jni.ldflags>
++ <tuxguitar-alsa.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -m64 -fPIC</tuxguitar-alsa.jni.cflags>
++ <tuxguitar-alsa.jni.ldflags>${LDFLAGS} -m64 -fPIC</tuxguitar-alsa.jni.ldflags>
+ <tuxguitar-alsa.jni.ldlibs>-lasound</tuxguitar-alsa.jni.ldlibs>
+ <tuxguitar-alsa.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-alsa.jni.ldpath>
+ <tuxguitar-alsa.jni.library.name>tuxguitar-alsa-jni</tuxguitar-alsa.jni.library.name>
+diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-fluidsynth-linux-armv7hl/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-fluidsynth-linux-armv7hl/pom.xml
+--- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-fluidsynth-linux-armv7hl/pom.xml 2016-12-22 21:04:26.000000000 +0100
++++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-fluidsynth-linux-armv7hl/pom.xml 2017-02-08 22:06:28.220720753 +0100
+@@ -24,8 +24,8 @@
+ <tuxguitar-fluidsynth.jni.path>${parent.relativePath}/TuxGuitar-fluidsynth/jni/</tuxguitar-fluidsynth.jni.path>
+ <tuxguitar-fluidsynth.jni.rm>${tuxguitar.jni.rm}</tuxguitar-fluidsynth.jni.rm>
+ <tuxguitar-fluidsynth.jni.cc>${tuxguitar.jni.cc}</tuxguitar-fluidsynth.jni.cc>
+- <tuxguitar-fluidsynth.jni.cflags>-I$(shell gcj -print-file-name=include/) -fPIC</tuxguitar-fluidsynth.jni.cflags>
+- <tuxguitar-fluidsynth.jni.ldflags>-fPIC</tuxguitar-fluidsynth.jni.ldflags>
++ <tuxguitar-fluidsynth.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -fPIC</tuxguitar-fluidsynth.jni.cflags>
++ <tuxguitar-fluidsynth.jni.ldflags>${LDFLAGS} -fPIC</tuxguitar-fluidsynth.jni.ldflags>
+ <tuxguitar-fluidsynth.jni.ldlibs>-lfluidsynth</tuxguitar-fluidsynth.jni.ldlibs>
+ <tuxguitar-fluidsynth.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-fluidsynth.jni.ldpath>
+ <tuxguitar-fluidsynth.jni.library.name>tuxguitar-fluidsynth-jni</tuxguitar-fluidsynth.jni.library.name>
+diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-fluidsynth-linux-x86/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-fluidsynth-linux-x86/pom.xml
+--- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-fluidsynth-linux-x86/pom.xml 2016-12-22 21:04:26.000000000 +0100
++++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-fluidsynth-linux-x86/pom.xml 2017-02-08 22:06:28.224054080 +0100
+@@ -24,8 +24,8 @@
+ <tuxguitar-fluidsynth.jni.path>${parent.relativePath}/TuxGuitar-fluidsynth/jni/</tuxguitar-fluidsynth.jni.path>
+ <tuxguitar-fluidsynth.jni.rm>${tuxguitar.jni.rm}</tuxguitar-fluidsynth.jni.rm>
+ <tuxguitar-fluidsynth.jni.cc>${tuxguitar.jni.cc}</tuxguitar-fluidsynth.jni.cc>
+- <tuxguitar-fluidsynth.jni.cflags>-I$(shell gcj -print-file-name=include/) -m32 -fPIC</tuxguitar-fluidsynth.jni.cflags>
+- <tuxguitar-fluidsynth.jni.ldflags>-m32 -fPIC</tuxguitar-fluidsynth.jni.ldflags>
++ <tuxguitar-fluidsynth.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -m32 -fPIC</tuxguitar-fluidsynth.jni.cflags>
++ <tuxguitar-fluidsynth.jni.ldflags>${LDFLAGS} -m32 -fPIC</tuxguitar-fluidsynth.jni.ldflags>
+ <tuxguitar-fluidsynth.jni.ldlibs>-lfluidsynth</tuxguitar-fluidsynth.jni.ldlibs>
+ <tuxguitar-fluidsynth.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-fluidsynth.jni.ldpath>
+ <tuxguitar-fluidsynth.jni.library.name>tuxguitar-fluidsynth-jni</tuxguitar-fluidsynth.jni.library.name>
+diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-fluidsynth-linux-x86_64/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-fluidsynth-linux-x86_64/pom.xml
+--- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-fluidsynth-linux-x86_64/pom.xml 2016-12-22 21:04:26.000000000 +0100
++++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-fluidsynth-linux-x86_64/pom.xml 2017-02-08 22:06:28.224054080 +0100
+@@ -24,8 +24,8 @@
+ <tuxguitar-fluidsynth.jni.path>${parent.relativePath}/TuxGuitar-fluidsynth/jni/</tuxguitar-fluidsynth.jni.path>
+ <tuxguitar-fluidsynth.jni.rm>${tuxguitar.jni.rm}</tuxguitar-fluidsynth.jni.rm>
+ <tuxguitar-fluidsynth.jni.cc>${tuxguitar.jni.cc}</tuxguitar-fluidsynth.jni.cc>
+- <tuxguitar-fluidsynth.jni.cflags>-I$(shell gcj -print-file-name=include/) -m64 -fPIC</tuxguitar-fluidsynth.jni.cflags>
+- <tuxguitar-fluidsynth.jni.ldflags>-m64 -fPIC</tuxguitar-fluidsynth.jni.ldflags>
++ <tuxguitar-fluidsynth.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -m64 -fPIC</tuxguitar-fluidsynth.jni.cflags>
++ <tuxguitar-fluidsynth.jni.ldflags>${LDFLAGS} -m64 -fPIC</tuxguitar-fluidsynth.jni.ldflags>
+ <tuxguitar-fluidsynth.jni.ldlibs>-lfluidsynth</tuxguitar-fluidsynth.jni.ldlibs>
+ <tuxguitar-fluidsynth.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-fluidsynth.jni.ldpath>
+ <tuxguitar-fluidsynth.jni.library.name>tuxguitar-fluidsynth-jni</tuxguitar-fluidsynth.jni.library.name>
+diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-jack-linux-armv7hl/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-jack-linux-armv7hl/pom.xml
+--- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-jack-linux-armv7hl/pom.xml 2016-12-22 21:04:26.000000000 +0100
++++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-jack-linux-armv7hl/pom.xml 2017-02-08 22:06:28.224054080 +0100
+@@ -24,8 +24,8 @@
+ <tuxguitar-jack.jni.path>${parent.relativePath}/TuxGuitar-jack/jni/</tuxguitar-jack.jni.path>
+ <tuxguitar-jack.jni.rm>${tuxguitar.jni.rm}</tuxguitar-jack.jni.rm>
+ <tuxguitar-jack.jni.cc>${tuxguitar.jni.cc}</tuxguitar-jack.jni.cc>
+- <tuxguitar-jack.jni.cflags>-I$(shell gcj -print-file-name=include/) -fPIC</tuxguitar-jack.jni.cflags>
+- <tuxguitar-jack.jni.ldflags>-fPIC</tuxguitar-jack.jni.ldflags>
++ <tuxguitar-jack.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -fPIC</tuxguitar-jack.jni.cflags>
++ <tuxguitar-jack.jni.ldflags>${LDFLAGS} -fPIC</tuxguitar-jack.jni.ldflags>
+ <tuxguitar-jack.jni.ldlibs>`pkg-config --libs jack`</tuxguitar-jack.jni.ldlibs>
+ <tuxguitar-jack.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-jack.jni.ldpath>
+ <tuxguitar-jack.jni.library.name>tuxguitar-jack-jni</tuxguitar-jack.jni.library.name>
+diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-jack-linux-x86/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-jack-linux-x86/pom.xml
+--- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-jack-linux-x86/pom.xml 2016-12-22 21:04:26.000000000 +0100
++++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-jack-linux-x86/pom.xml 2017-02-08 22:06:28.224054080 +0100
+@@ -24,8 +24,8 @@
+ <tuxguitar-jack.jni.path>${parent.relativePath}/TuxGuitar-jack/jni/</tuxguitar-jack.jni.path>
+ <tuxguitar-jack.jni.rm>${tuxguitar.jni.rm}</tuxguitar-jack.jni.rm>
+ <tuxguitar-jack.jni.cc>${tuxguitar.jni.cc}</tuxguitar-jack.jni.cc>
+- <tuxguitar-jack.jni.cflags>-I$(shell gcj -print-file-name=include/) -m32 -fPIC</tuxguitar-jack.jni.cflags>
+- <tuxguitar-jack.jni.ldflags>-m32 -fPIC</tuxguitar-jack.jni.ldflags>
++ <tuxguitar-jack.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -m32 -fPIC</tuxguitar-jack.jni.cflags>
++ <tuxguitar-jack.jni.ldflags>${LDFLAGS} -m32 -fPIC</tuxguitar-jack.jni.ldflags>
+ <tuxguitar-jack.jni.ldlibs>`pkg-config --libs jack`</tuxguitar-jack.jni.ldlibs>
+ <tuxguitar-jack.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-jack.jni.ldpath>
+ <tuxguitar-jack.jni.library.name>tuxguitar-jack-jni</tuxguitar-jack.jni.library.name>
+diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-jack-linux-x86_64/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-jack-linux-x86_64/pom.xml
+--- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-jack-linux-x86_64/pom.xml 2016-12-22 21:04:26.000000000 +0100
++++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-jack-linux-x86_64/pom.xml 2017-02-08 22:06:28.224054080 +0100
+@@ -24,8 +24,8 @@
+ <tuxguitar-jack.jni.path>${parent.relativePath}/TuxGuitar-jack/jni/</tuxguitar-jack.jni.path>
+ <tuxguitar-jack.jni.rm>${tuxguitar.jni.rm}</tuxguitar-jack.jni.rm>
+ <tuxguitar-jack.jni.cc>${tuxguitar.jni.cc}</tuxguitar-jack.jni.cc>
+- <tuxguitar-jack.jni.cflags>-I$(shell gcj -print-file-name=include/) -m64 -fPIC</tuxguitar-jack.jni.cflags>
+- <tuxguitar-jack.jni.ldflags>-m64 -fPIC</tuxguitar-jack.jni.ldflags>
++ <tuxguitar-jack.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -m64 -fPIC</tuxguitar-jack.jni.cflags>
++ <tuxguitar-jack.jni.ldflags>${LDFLAGS} -m64 -fPIC</tuxguitar-jack.jni.ldflags>
+ <tuxguitar-jack.jni.ldlibs>`pkg-config --libs jack`</tuxguitar-jack.jni.ldlibs>
+ <tuxguitar-jack.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-jack.jni.ldpath>
+ <tuxguitar-jack.jni.library.name>tuxguitar-jack-jni</tuxguitar-jack.jni.library.name>
+diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-oss-linux-armv7hl/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-oss-linux-armv7hl/pom.xml
+--- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-oss-linux-armv7hl/pom.xml 2016-12-22 21:04:26.000000000 +0100
++++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-oss-linux-armv7hl/pom.xml 2017-02-08 22:06:28.224054080 +0100
+@@ -22,8 +22,8 @@
+
+ <tuxguitar-oss.jni.path>${parent.relativePath}/TuxGuitar-oss/jni/</tuxguitar-oss.jni.path>
+ <tuxguitar-oss.jni.cc>${tuxguitar.jni.cc}</tuxguitar-oss.jni.cc>
+- <tuxguitar-oss.jni.cflags>-I$(shell gcj -print-file-name=include/) -fPIC</tuxguitar-oss.jni.cflags>
+- <tuxguitar-oss.jni.ldflags>-fPIC</tuxguitar-oss.jni.ldflags>
++ <tuxguitar-oss.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -fPIC</tuxguitar-oss.jni.cflags>
++ <tuxguitar-oss.jni.ldflags>${LDFLAGS} -fPIC</tuxguitar-oss.jni.ldflags>
+ <tuxguitar-oss.jni.ldlibs></tuxguitar-oss.jni.ldlibs>
+ <tuxguitar-oss.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-oss.jni.ldpath>
+ <tuxguitar-oss.jni.library.name>tuxguitar-oss-jni</tuxguitar-oss.jni.library.name>
+diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-oss-linux-x86/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-oss-linux-x86/pom.xml
+--- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-oss-linux-x86/pom.xml 2016-12-22 21:04:26.000000000 +0100
++++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-oss-linux-x86/pom.xml 2017-02-08 22:06:28.224054080 +0100
+@@ -22,8 +22,8 @@
+
+ <tuxguitar-oss.jni.path>${parent.relativePath}/TuxGuitar-oss/jni/</tuxguitar-oss.jni.path>
+ <tuxguitar-oss.jni.cc>${tuxguitar.jni.cc}</tuxguitar-oss.jni.cc>
+- <tuxguitar-oss.jni.cflags>-I$(shell gcj -print-file-name=include/) -m32 -fPIC</tuxguitar-oss.jni.cflags>
+- <tuxguitar-oss.jni.ldflags>-m32 -fPIC</tuxguitar-oss.jni.ldflags>
++ <tuxguitar-oss.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -m32 -fPIC</tuxguitar-oss.jni.cflags>
++ <tuxguitar-oss.jni.ldflags>${LDFLAGS} -m32 -fPIC</tuxguitar-oss.jni.ldflags>
+ <tuxguitar-oss.jni.ldlibs></tuxguitar-oss.jni.ldlibs>
+ <tuxguitar-oss.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-oss.jni.ldpath>
+ <tuxguitar-oss.jni.library.name>tuxguitar-oss-jni</tuxguitar-oss.jni.library.name>
+diff -u -r tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-oss-linux-x86_64/pom.xml tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-oss-linux-x86_64/pom.xml
+--- tuxguitar-1.4-src/build-scripts/native-modules/tuxguitar-oss-linux-x86_64/pom.xml 2016-12-22 21:04:26.000000000 +0100
++++ tuxguitar-1.4-src-nogcj/build-scripts/native-modules/tuxguitar-oss-linux-x86_64/pom.xml 2017-02-08 22:06:28.224054080 +0100
+@@ -22,8 +22,8 @@
+
+ <tuxguitar-oss.jni.path>${parent.relativePath}/TuxGuitar-oss/jni/</tuxguitar-oss.jni.path>
+ <tuxguitar-oss.jni.cc>${tuxguitar.jni.cc}</tuxguitar-oss.jni.cc>
+- <tuxguitar-oss.jni.cflags>-I$(shell gcj -print-file-name=include/) -m64 -fPIC</tuxguitar-oss.jni.cflags>
+- <tuxguitar-oss.jni.ldflags>-m64 -fPIC</tuxguitar-oss.jni.ldflags>
++ <tuxguitar-oss.jni.cflags>${CFLAGS} -I${JAVA_HOME}/include -I${JAVA_HOME}/include/linux -m64 -fPIC</tuxguitar-oss.jni.cflags>
++ <tuxguitar-oss.jni.ldflags>${LDFLAGS} -m64 -fPIC</tuxguitar-oss.jni.ldflags>
+ <tuxguitar-oss.jni.ldlibs></tuxguitar-oss.jni.ldlibs>
+ <tuxguitar-oss.jni.ldpath>${tuxguitar.jni.ldpath}</tuxguitar-oss.jni.ldpath>
+ <tuxguitar-oss.jni.library.name>tuxguitar-oss-jni</tuxguitar-oss.jni.library.name>
diff --git a/tuxguitar.desktop b/tuxguitar.desktop
new file mode 100644
index 000000000000..4bb6a96584a9
--- /dev/null
+++ b/tuxguitar.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Version=1.0
+Name=tuxguitar
+Comment=Edit, playback guitar tablatures
+Comment[fr]=Edite, joue des tablatures de guitare
+Comment[es]=Edita, reproduce tablaturas de guitarra
+Exec=tuxguitar %F
+Icon=tuxguitar
+Terminal=false
+Type=Application
+Categories=Application;AudioVideo;Audio;
+MimeType=audio/x-tuxguitar;audio/x-gtp;audio/x-ptb;
+#eof "$Id: tuxguitar.desktop,v 1.2 2008/09/15 07:54:28 sergej Exp $"
diff --git a/tuxguitar.xml b/tuxguitar.xml
new file mode 100644
index 000000000000..4c85c8f4eec6
--- /dev/null
+++ b/tuxguitar.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="audio/x-tuxguitar">
+ <comment>TuxGuitar file</comment>
+ <glob pattern="*.tg"/>
+ </mime-type>
+ <mime-type type="audio/x-gtp">
+ <comment>GuitarPro file</comment>
+ <glob pattern="*.gtp"/>
+ <glob pattern="*.gp3"/>
+ <glob pattern="*.gp4"/>
+ <glob pattern="*.gp5"/>
+ <glob pattern="*.gpx"/>
+ </mime-type>
+ <mime-type type="audio/x-ptb">
+ <comment>PowerTab file</comment>
+ <glob pattern="*.ptb"/>
+ </mime-type>
+</mime-info>