summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09d303f4dd5c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = twisted-web2
+ pkgdesc = The twisted.web2 package in Twisted.
+ pkgver = 8.1.0
+ pkgrel = 4
+ url = http://twistedmatrix.com/
+ arch = any
+ license = MIT
+ depends = twisted
+ depends = python2
+ conflicts = twisted-web
+ source = http://twistedmatrix.com/Releases/Web2/8.1/TwistedWeb2-8.1.0.tar.bz2
+ md5sums = e34b48edf6fef075bd41ddbd215aed32
+
+pkgname = twisted-web2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbbe30ea3648
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Contributor: Paul Nicholson <brenix@gmail.com>
+# Contributor: Nathan Jones <nathanj@insightbb.com>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=twisted-web2
+pkgver=8.1.0
+pkgrel=4
+pkgdesc="The twisted.web2 package in Twisted."
+arch=('any')
+url="http://twistedmatrix.com/"
+license=('MIT')
+depends=('twisted' 'python2')
+conflicts=('twisted-web')
+source=("http://twistedmatrix.com/Releases/Web2/8.1/TwistedWeb2-8.1.0.tar.bz2")
+md5sums=('e34b48edf6fef075bd41ddbd215aed32')
+
+package() {
+ cd TwistedWeb2-8.1.0
+ python2 setup.py install --prefix=/usr --root=$pkgdir
+ install -D -m644 LICENSE \
+ $pkgdir/usr/share/licenses/twisted-web2/LICENSE
+}