summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
2 files changed, 23 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d1a87abd61b..e19fdc72c487 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,22 @@
pkgbase = twitch-indicator
pkgdesc = Twitch indicator for Linux. Tracks your followed channels and notifies when they go live.
- pkgver = 1.6
+ pkgver = 1.7
pkgrel = 1
url = https://github.com/buzz/twitch-indicator
arch = any
license = GPL
+ makedepends = desktop-file-utils
makedepends = git
- depends = python
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-hatch
+ depends = python-aiofiles
+ depends = python-aiohttp
depends = python-gobject
- depends = desktop-file-utils
- depends = libappindicator-gtk3
+ depends = python
+ depends = xapp
options = !emptydirs
- source = git+https://github.com/buzz/twitch-indicator.git#tag=1.6
+ source = git+https://github.com/buzz/twitch-indicator.git#tag=1.7
md5sums = SKIP
pkgname = twitch-indicator
diff --git a/PKGBUILD b/PKGBUILD
index b4ff8d40d093..1a6772500ec1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,29 @@
# Maintainer: buzz
# Contributor: dude <brrtsm-AT-gmail-DOT-com>
pkgname=twitch-indicator
-_gitname=twitch-indicator
-pkgver=1.6
+pkgver=1.7
pkgrel=1
pkgdesc="Twitch indicator for Linux. Tracks your followed channels and notifies when they go live."
arch=("any")
url="https://github.com/buzz/twitch-indicator"
license=("GPL")
-depends=("python" "python-gobject" "desktop-file-utils" "libappindicator-gtk3")
-makedepends=("git")
+depends=("python-aiofiles" "python-aiohttp" "python-gobject" "python" "xapp")
+makedepends=("desktop-file-utils" "git" "python-build" "python-installer" "python-hatch")
options=(!emptydirs)
source=("git+https://github.com/buzz/twitch-indicator.git#tag=${pkgver}")
md5sums=("SKIP")
+build() {
+ cd "${pkgname}"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "${_gitname}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ cd "${pkgname}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+ install -Dm644 data/twitch-indicator.desktop "${pkgdir}/usr/share/applications/twitch-indicator.desktop"
+ install -Dm644 data/apps.twitch-indicator.gschema.xml "${pkgdir}/usr/share/glib-2.0/schemas/apps.twitch-indicator.gschema.xml"
+ install -Dm644 twitch_indicator/data/twitch-indicator.svg "${pkgdir}/usr/share/icons/twitch-indicator.svg"
}
# vim:set ts=2 sw=2 et: