summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--twp.install1
-rw-r--r--twp.service2
4 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 726150a8abec..ca2cdd48bbea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri May 23 11:49:42 UTC 2016
+# Fri May 27 12:50:50 UTC 2016
pkgbase = twp
pkgdesc = Teeworlds Web Panel for management of local Teeworlds servers
pkgver = 0.3.0
@@ -20,11 +20,13 @@ pkgbase = twp
depends = python2-dateutil
depends = python2-flask-wtf
depends = python2-webassets
+ depends = python2-flask-assets
+ depends = python2-jsmin
backup = srv/twp/twp.conf
source = twp-0.3.0.zip::https://github.com/CytraL/twp/archive/0.3.0.zip
source = twp.service
md5sums = SKIP
- md5sums = 35f1a63755f15e41b31d9988f4f56a11
+ md5sums = 50b2b3808bea9a33081de2596b67f689
pkgname = twp
diff --git a/PKGBUILD b/PKGBUILD
index 78b4b59e0961..2f3018f3b57d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,21 +11,26 @@ license=('AGPL')
depends=(sqlite3 python2-flask-babel python2-flask-apscheduler python2-pillow
python2-sqlalchemy python2-mergedict python2-singledispatch
python2-flask-sqlalchemy python2-dateutil python2-flask-wtf
- python2-webassets python2-flask-assets)
+ python2-webassets python2-flask-assets python2-jsmin)
makedepends=(unzip)
install=twp.install
backup=(srv/twp/twp.conf)
source=("$pkgname-$pkgver.zip::https://github.com/CytraL/$pkgname/archive/$pkgver.zip"
"twp.service")
md5sums=('SKIP'
- '35f1a63755f15e41b31d9988f4f56a11')
+ '50b2b3808bea9a33081de2596b67f689')
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 test.py
+}
package() {
# install systemd service file
install -Dm644 "twp.service" "$pkgdir/usr/lib/systemd/system/twp.service"
# enter and install files in the pkgdir
- install -dm755 "$pkgdir/srv/twp/"
+ install -dm2755 "$pkgdir/srv/twp/"
cd "$pkgdir/srv/twp/"
cp -a "$srcdir/$pkgname-$pkgver"/* .
diff --git a/twp.install b/twp.install
index 589d83320fe6..8c723461ad8b 100644
--- a/twp.install
+++ b/twp.install
@@ -10,5 +10,4 @@ post_install () {
post_upgrade() {
# Fix permissions on necessary directories
chown -R twp:twp /srv/twp
- chmod g+s /srv/twp
}
diff --git a/twp.service b/twp.service
index d8e87504b51f..f66e97c434aa 100644
--- a/twp.service
+++ b/twp.service
@@ -5,7 +5,7 @@ After=network.target
[Service]
User=twp
Type=simple
-ExecStart=/usr/bin/python2 /srv/twp/run.py
+ExecStart=/srv/twp/run.py
WorkingDirectory=/srv/twp
[Install]