summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31653942e1e1..cbc4fa964a76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = typography
pkgdesc = Tool for working with the GNOME typography design guidelines
- pkgver = 0.1.0
+ pkgver = 0.2.0
pkgrel = 1
url = https://gitlab.gnome.org/World/design/typography
- arch = any
+ arch = x86_64
license = GPL3
checkdepends = appstream-glib
makedepends = meson
depends = gtk4
- source = https://gitlab.gnome.org/World/design/typography/-/archive/0.1.0/typography-0.1.0.tar.gz
- sha256sums = 7990df024495c6018f066273b91ab8f6bf27e4ea2dc2f506bc18420b4ed769b0
+ depends = libadwaita
+ source = https://gitlab.gnome.org/World/design/typography/-/archive/0.2.0/typography-0.2.0.tar.gz
+ b2sums = 6efd047840ba1b0b9b231e73e0e2a0ffc10d134f152ae73181c2574192dca57fc2a33fdb8845a71cda43d1c9a27d3332f8ed42ed0676a4c6d4e0579c09ea3202
pkgname = typography
diff --git a/PKGBUILD b/PKGBUILD
index 70106f1e43b8..b22f2e3f8ed2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
pkgname=typography
-pkgver=0.1.0
+pkgver=0.2.0
pkgrel=1
pkgdesc="Tool for working with the GNOME typography design guidelines"
-arch=('any')
+arch=('x86_64')
url="https://gitlab.gnome.org/World/design/typography"
license=('GPL3')
-depends=('gtk4')
+depends=('gtk4' 'libadwaita')
makedepends=('meson')
checkdepends=('appstream-glib')
source=($url/-/archive/$pkgver/$pkgname-$pkgver.tar.gz)
-sha256sums=('7990df024495c6018f066273b91ab8f6bf27e4ea2dc2f506bc18420b4ed769b0')
+b2sums=('6efd047840ba1b0b9b231e73e0e2a0ffc10d134f152ae73181c2574192dca57fc2a33fdb8845a71cda43d1c9a27d3332f8ed42ed0676a4c6d4e0579c09ea3202')
build() {
arch-meson $pkgname-$pkgver build
@@ -19,9 +19,9 @@ build() {
}
check() {
- meson test -C build --print-errorlogs
+ meson test -C build
}
package() {
- DESTDIR="${pkgdir}" meson install -C build
-} \ No newline at end of file
+ meson install -C build --destdir "$pkgdir"
+}