summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD34
-rw-r--r--typora-theme-drake.install20
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4bc1e662f2a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = typora-theme-drake-git
+ pkgdesc = Material Google JetBrains Vue Juejin Purple Ayu Dark .
+ pkgver = 2.9.6
+ pkgrel = 1
+ url = https://github.com/liangjingkanji/DrakeTyporaTheme
+ install = typora-theme-drake.install
+ arch = any
+ license = MIT
+ makedepends = git
+ optdepends = ttf-jetbrains-mono-git: 适合开发人员的编程字体
+ optdepends = otf-fira-code-git: 前端开发人员喜欢用的字体
+ optdepends = ttf-delugia-code: 微软官方字体, Windows Terminal的默认字体
+ optdepends = ttf-sarasa-gothic-sc: 更紗黑體, 超窄字间距(稍微过窄)
+ provides = typora-theme-drake
+ conflicts = typora-theme-drake
+ source = typora-theme-drake::git+https://github.com/liangjingkanji/DrakeTyporaTheme.git
+ sha256sums = SKIP
+
+pkgname = typora-theme-drake-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c0c93afe1579
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.zst
+src
+pkg
+typora-theme-drake
+DrakeTyporaTheme \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f93d3a50e0a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: witt <1989161762 at qq dot com>
+pkgname=typora-theme-drake-git
+pkgver=2.9.6
+pkgrel=1
+pkgdesc="Material Google JetBrains Vue Juejin Purple Ayu Dark ."
+arch=('any')
+url="https://github.com/liangjingkanji/DrakeTyporaTheme"
+license=('MIT')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
+makedepends=(
+ 'git'
+)
+optdepends=('ttf-jetbrains-mono-git: 适合开发人员的编程字体'
+ 'otf-fira-code-git: 前端开发人员喜欢用的字体'
+ 'ttf-delugia-code: 微软官方字体, Windows Terminal的默认字体'
+ 'ttf-sarasa-gothic-sc: 更紗黑體, 超窄字间距(稍微过窄)'
+)
+install="${pkgname%-git}.install"
+source=(
+ "${pkgname%-git}::git+${url}.git"
+)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/v//g'
+}
+
+package() {
+ install -Dm644 "${srcdir}/${pkgname%-git}/"*.css -t "${pkgdir}/${HOME}/.config/Typora/themes"
+ install -Dm644 "${srcdir}/${pkgname%-git}/drake/"*.css -t "${pkgdir}/${HOME}/.config/Typora/themes/drake"
+ install -Dm644 "${srcdir}/${pkgname%-git}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
diff --git a/typora-theme-drake.install b/typora-theme-drake.install
new file mode 100644
index 000000000000..8fe423249e4f
--- /dev/null
+++ b/typora-theme-drake.install
@@ -0,0 +1,20 @@
+post_install() {
+ ECHOLEN=$(echo -e|awk '{print length($0)}')
+ if [ "${ECHOLEN}" = '0' ]
+ then
+ ECHO='echo -e'
+ else
+ ECHO='echo'
+ fi
+
+ $ECHO "\033[36m******************************************************************************************\033[0m"
+ $ECHO "\033[36m 修改字体大小: 设置界面->外观->字体大小->设置字体大小 \033[0m"
+ $ECHO "\033[36m 自定义字体请编辑: ~/.config/Typora/themes/drake/font.css#L35-L37 \033[0m"
+ $ECHO "\033[36m 行高/段间距请编辑:~/.config/Typora/themes/drake/font.css#L38-L40 \033[0m"
+ $ECHO "\033[36m 其他问题查看:https://github.com/liangjingkanji/DrakeTyporaTheme/blob/master/issues.md \033[0m"
+ $ECHO "\033[36m******************************************************************************************\033[0m"
+}
+
+post_upgrade() {
+ post_install
+} \ No newline at end of file