summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD9
-rw-r--r--ulogviewer.sh2
3 files changed, 15 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 665116388f98..a81a1f49d316 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ulogviewer-bin
pkgdesc = Cross-Platform Universal Log Viewer.
- pkgver = 4.0.8.303
+ pkgver = 4.0.9.331
pkgrel = 1
url = https://carina-studio.github.io/ULogViewer/
arch = aarch64
@@ -13,17 +13,17 @@ pkgbase = ulogviewer-bin
optdepends = android-sdk-platform-tools
optdepends = git
optdepends = libimobiledevice
- provides = ulogviewer=4.0.8.303
+ provides = ulogviewer=4.0.9.331
conflicts = ulogviewer
- noextract = ulogviewer-4.0.8.303-x86_64.zip
+ noextract = ulogviewer-4.0.9.331-x86_64.zip
options = !strip
- source = LICENSE-4.0.8.303::https://raw.githubusercontent.com/carina-studio/ULogViewer/4.0.8.303/LICENSE
+ source = LICENSE-4.0.9.331::https://raw.githubusercontent.com/carina-studio/ULogViewer/4.0.9.331/LICENSE
source = ulogviewer.sh
sha256sums = 4b023d792eb6b929311286a207c6493e18875bd9d320db8f7a996dd5d5716fea
- sha256sums = b5655aeda6af46f693ab0b78c69e313f2db718cc75fb707e0160637158239aa1
- source_aarch64 = ulogviewer-4.0.8.303-aarch64.zip::https://github.com/carina-studio/ULogViewer/releases/download/4.0.8.303/ULogViewer-4.0.8.303-linux-arm64.zip
- sha256sums_aarch64 = f3cf317f2c29a9dcf94299e1fbb969653ae8274ba54b02cad21672bc1c9c2c73
- source_x86_64 = ulogviewer-4.0.8.303-x86_64.zip::https://github.com/carina-studio/ULogViewer/releases/download/4.0.8.303/ULogViewer-4.0.8.303-linux-x64.zip
- sha256sums_x86_64 = 769c3e0e74d8ffe87cf00d6c72a288b6692db90fd889ab18bf6aa03065c29d9f
+ sha256sums = 15c97baa7cb5db54234f94cc9ff8d2b3487f2f1a243bef95d7f4fa8a30c78469
+ source_aarch64 = ulogviewer-4.0.9.331-aarch64.zip::https://github.com/carina-studio/ULogViewer/releases/download/4.0.9.331/ULogViewer-4.0.9.331-linux-arm64.zip
+ sha256sums_aarch64 = 4ec41cabd4411f7e63488fabd1cb9909605944a721f994f0487683b96392a96a
+ source_x86_64 = ulogviewer-4.0.9.331-x86_64.zip::https://github.com/carina-studio/ULogViewer/releases/download/4.0.9.331/ULogViewer-4.0.9.331-linux-x64.zip
+ sha256sums_x86_64 = 0a8b67a32345caf2e93c8a2b0311970bc906f004f4acae824d9c94f86341b3fa
pkgname = ulogviewer-bin
diff --git a/PKGBUILD b/PKGBUILD
index 37220bb0cfef..0fdd2e641f91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=ulogviewer-bin
_pkgname=ULogViewer
-pkgver=4.0.8.303
+pkgver=4.0.9.331
pkgrel=1
pkgdesc="Cross-Platform Universal Log Viewer."
arch=(
@@ -35,9 +35,9 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('4b023d792eb6b929311286a207c6493e18875bd9d320db8f7a996dd5d5716fea'
- 'b5655aeda6af46f693ab0b78c69e313f2db718cc75fb707e0160637158239aa1')
-sha256sums_aarch64=('f3cf317f2c29a9dcf94299e1fbb969653ae8274ba54b02cad21672bc1c9c2c73')
-sha256sums_x86_64=('769c3e0e74d8ffe87cf00d6c72a288b6692db90fd889ab18bf6aa03065c29d9f')
+ '15c97baa7cb5db54234f94cc9ff8d2b3487f2f1a243bef95d7f4fa8a30c78469')
+sha256sums_aarch64=('4ec41cabd4411f7e63488fabd1cb9909605944a721f994f0487683b96392a96a')
+sha256sums_x86_64=('0a8b67a32345caf2e93c8a2b0311970bc906f004f4acae824d9c94f86341b3fa')
build() {
sed -e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|${_pkgname}|g" \
@@ -46,6 +46,7 @@ build() {
bsdtar -xf "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.zip" -C "${srcdir}/opt/${pkgname%-bin}"
gendesk -q -f -n --categories="Utility" --name="${_pkgname}" --exec="${pkgname%-bin} %U"
chmod 755 "${srcdir}/opt/${pkgname%-bin}/${_pkgname}"
+ rm -rf "${srcdir}/opt/${pkgname%-bin}/__MACOSX"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/ulogviewer.sh b/ulogviewer.sh
index c830cd20b916..26ab42df8de4 100644
--- a/ulogviewer.sh
+++ b/ulogviewer.sh
@@ -1,4 +1,4 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/opt/@appname@"
_RUNNAME="${_APPDIR}/@runname@"