summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD21
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48c489645c01
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = umicons
+ pkgdesc = Created Icons by mattahan
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://www.deviantart.com/mattahan/art/Umicons-Volume-3-2211092
+ arch = any
+ license = cc-by-nc-sa
+ source = https://github.com/robson-66/Umicons/archive/refs/heads/master.zip
+ sha256sums = SKIP
+
+pkgname = umicons
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa4a003cffe1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Robert Brzozowski <robson75@linux.pl>
+
+pkgname=umicons
+pkgver=1.0
+pkgrel=1
+pkgdesc="Created Icons by mattahan"
+arch=('any')
+url="https://www.deviantart.com/mattahan/art/Umicons-Volume-3-2211092"
+license=('cc-by-nc-sa')
+
+source=("https://github.com/robson-66/Umicons/archive/refs/heads/master.zip")
+sha256sums=('SKIP')
+
+package() {
+ mkdir -p "$pkgdir"/usr/share/icons/
+ cp -R "$srcdir"/Umicons*/ "$pkgdir"/usr/share/icons/Umicons/
+
+ find $pkgdir/usr -type f -exec chmod 644 {} \;
+ find $pkgdir/usr -type d -exec chmod 755 {} \;
+ find $pkgdir/usr -type f -name '.directory' -delete
+}