summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore9
-rw-r--r--LICENSE2
-rw-r--r--PKGBUILD48
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b27b2206662
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = undither
+ pkgdesc = Remove dither effects from scanned images
+ pkgver = 20021015
+ pkgrel = 1
+ url = http://www.madingley.org/james/resources/undither/
+ arch = x86_64
+ arch = i686
+ license = Custom
+ makedepends = wget
+ depends = fftw2
+ source = http://www.madingley.org/james/resources/undither/files/undither-20021015.tar.gz
+ source = LICENSE
+ sha256sums = 76241e87e64df3c7723c966ca71019e930e1473bb570de4c45e24a3340231b7f
+ sha256sums = SKIP
+
+pkgname = undither
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8e995fb46250
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+# Package directories
+pkg/
+src/
+
+# Built packages
+*.pkg.tar.*
+
+# Source Files
+*.tar.gz
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..e8a92832a24d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,2 @@
+Copyright (c) 2001-2002 James McKenzie <james@fishsoup.dhs.org>,
+All rights reserved.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb9005dd342d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Oliver Kahrmann <oliver.kahrmann@gmail.com>
+
+pkgname=undither
+pkgver=20021015
+pkgrel=1
+pkgdesc="Remove dither effects from scanned images"
+arch=('x86_64' 'i686')
+url="http://www.madingley.org/james/resources/undither/"
+license=('Custom')
+depends=('fftw2')
+makedepends=('wget')
+source=(
+ "http://www.madingley.org/james/resources/undither/files/undither-$pkgver.tar.gz"
+ "LICENSE"
+)
+sha256sums=(
+ '76241e87e64df3c7723c966ca71019e930e1473bb570de4c45e24a3340231b7f'
+ 'SKIP'
+)
+
+prepare() {
+ # Replace fttw header filenames and library names to adjust for fftw2 package
+ sed "s/<fftw.h>/<sfftw.h>/" -i "$srcdir/undither/undither.c"
+ sed "s/<rfftw.h>/<srfftw.h>/" -i "$srcdir/undither/undither.c"
+
+ sed "s/-lfftw/-lsfftw/" -i "$srcdir/undither/Makefile"
+ sed "s/-lrfftw/-lsrfftw/" -i "$srcdir/undither/Makefile"
+
+ # Download the explanation on the website as documentation
+ wget -P $srcdir/undither-doc -r -nH -nd -np -nc -k -A html,gif,jpg "http://www.madingley.org/james/resources/undither/"
+}
+
+build() {
+ cd "$srcdir/undither"
+ make FFTW="$destdir/usr" undither
+}
+
+package() {
+ cd "$srcdir/undither"
+ mkdir -p $pkgdir/usr/bin
+ make BINDIR="$pkgdir/usr/bin" FFTW="$destdir/usr" install
+
+ install -Dm644 "${srcdir}/undither/README" "${pkgdir}/usr/share/doc/${pkgname}/README"
+ install -Dm644 "${srcdir}/undither-doc/"* "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: