summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD30
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f07babe1f32d..3137e16d87d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = uno-calculator-bin
pkgdesc = Windows Calculator ported to Linux by Uno Platform (extracted from Snap package)
pkgver = 1.2.9_uno.339
- pkgrel = 1
+ pkgrel = 2
url = https://platform.uno/uno-calculator/
arch = x86_64
license = Apache-2.0
diff --git a/PKGBUILD b/PKGBUILD
index ad268c7b8768..5286c59fb420 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,6 @@
# Maintainer: bemxio <bemxiov at protonmail dot com>
+# Contributor: Caltlgin Stsodaat <contact at fossdaily dot xyz>
+# Contributor: Yamada Hayao <shun819.mail at gmail dot com>
pkgname=uno-calculator-bin
@@ -6,7 +8,7 @@ _pkgdesc="Windows Calculator ported to Linux by Uno Platform"
pkgdesc="${_pkgdesc} (extracted from Snap package)"
pkgver=1.2.9_uno.339
-pkgrel=1
+pkgrel=2
arch=(x86_64)
@@ -25,15 +27,15 @@ source=("uno-calculator.snap::$(echo ${_snap_info} | jq -r .download_url)" "uno-
sha512sums=("$(echo ${_snap_info} | jq -r .download_sha512)" "6e364ba1505dc5211a49d36534f498eadadd75f8ecbd8e6ade8aed9e06fd9afdbe54c2e4b3a632fe109b46546c084b5aef44e4e938ad281a2a261f190c92ac48")
pkgver() {
- # get the version from the Snapcraft API
- echo ${_snap_info} | jq -r .version | sed "s/-/_/"
+ # get the version from the Snapcraft API
+ echo ${_snap_info} | jq -r .version | sed "s/-/_/"
}
prepare() {
- # extract the Snap package
- unsquashfs -force -info uno-calculator.snap
+ # extract the Snap package
+ unsquashfs -force -info uno-calculator.snap
- # generate a .desktop file
+ # generate a .desktop file
gendesk -f -n \
--pkgname "Uno Calculator" \
--pkgdesc "${_pkgdesc}" \
@@ -43,16 +45,16 @@ prepare() {
}
package() {
- # move to the extracted directory
- cd squashfs-root
+ # move to the extracted directory
+ cd squashfs-root
- # copy the files to the package directory
- find . -type f -exec install -D {} "${pkgdir}/opt/uno-calculator/{}" \;
+ # copy the files to the package directory
+ find . -type f -exec install -D {} "${pkgdir}/opt/uno-calculator/{}" \;
- # copy the icon and the generated .desktop file
- install -Dm644 meta/gui/icon.png "${pkgdir}/usr/share/pixmaps/uno-calculator.png"
+ # copy the icon and the generated .desktop file
+ install -Dm644 meta/gui/icon.png "${pkgdir}/usr/share/pixmaps/uno-calculator.png"
install -Dm644 "../Uno Calculator.desktop" "${pkgdir}/usr/share/applications/uno-calculator.desktop"
- # copy the executable script
- install -Dm755 ../uno-calculator "${pkgdir}/usr/bin/uno-calculator"
+ # copy the executable script
+ install -Dm755 ../uno-calculator "${pkgdir}/usr/bin/uno-calculator"
} \ No newline at end of file