summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD34
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..227a17d522a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = unpack-git
+ pkgdesc = Wrapper script for handling multiple archive formats
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/githaff/unpack
+ arch = any
+ license = BSD
+ depends = sh
+ optdepends = bzip2: bz2 support
+ optdepends = gzip: gz support
+ optdepends = xz: xz support
+ optdepends = lzop: lzo support
+ optdepends = rpm-org: rpm support
+ optdepends = unrar: rar support
+ optdepends = unzip: zip support
+ optdepends = p7zip: 7z support
+ provides = unpack-git
+ conflicts = unpack-git
+ source = git+https://github.com/githaff/unpack.git
+ md5sums = SKIP
+
+pkgname = unpack-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b88633c27d00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Dmitry Lavnikevich <haff@midgard.by>
+
+pkgname=unpack-git
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Wrapper script for handling multiple archive formats"
+arch=('any')
+url="https://github.com/githaff/unpack"
+license=('BSD')
+depends=('sh')
+makedepends=()
+optdepends=('bzip2: bz2 support'
+ 'gzip: gz support'
+ 'xz: xz support'
+ 'lzop: lzo support'
+ 'rpm-org: rpm support'
+ 'unrar: rar support'
+ 'unzip: zip support'
+ 'p7zip: 7z support')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+source=("git+https://github.com/githaff/unpack.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+ ./unpack --version
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-git}"
+ install -D -m755 unpack "${pkgdir}/usr/bin/unpack"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}