summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rwxr-xr-xunreal-engine-4.sh12
3 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0dd60d5f6b65..e2e579ca9598 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -40,7 +40,7 @@ pkgbase = unreal-engine-4
source = clang_path_fix.patch
source = ccache_executor.patch
source = unreal-engine-4-pacman-cache.hook
- sha256sums = 45a9ca2d3f70501c1d2eba3b78a453c98c1aecb0e9f4273cacebc6229d972dc6
+ sha256sums = 42be68b1a709db22d04ac2de96334ac7f44b86944777caa418b1ab35545c24df
sha256sums = c04c03b2c5c933b7eb1af283d607934ad95fd57f44d62b83719061b555a85dca
sha256sums = 960c5a100e0c3732f3c73fb645d3989d39acf4576d74615bbef38ebeee008b90
sha256sums = 33982486f7fafac35a33dfa37c85cfba8543aa78b5fe13c395d9cccf691ef4b3
diff --git a/PKGBUILD b/PKGBUILD
index 9fd54edc7c1a..e25eea7a840b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ source=('unreal-engine-4.sh'
'clang_path_fix.patch'
'ccache_executor.patch'
'unreal-engine-4-pacman-cache.hook')
-sha256sums=('45a9ca2d3f70501c1d2eba3b78a453c98c1aecb0e9f4273cacebc6229d972dc6'
+sha256sums=('42be68b1a709db22d04ac2de96334ac7f44b86944777caa418b1ab35545c24df'
'c04c03b2c5c933b7eb1af283d607934ad95fd57f44d62b83719061b555a85dca'
'960c5a100e0c3732f3c73fb645d3989d39acf4576d74615bbef38ebeee008b90'
'33982486f7fafac35a33dfa37c85cfba8543aa78b5fe13c395d9cccf691ef4b3'
diff --git a/unreal-engine-4.sh b/unreal-engine-4.sh
index 6c127fca307f..0433bd646975 100755
--- a/unreal-engine-4.sh
+++ b/unreal-engine-4.sh
@@ -1,15 +1,23 @@
#! /usr/bin/bash
+## I keep getting this question/comment, so I'll explain the reason for this here for those who feel compelled to ask again:
+# This file mainly exists to stop stubborn people who have a bad habit of running everything as root and to make sure specific paths exists to avoid arbitrary legacy compatibility issues.
+# It also assists with determining user-chosen custom install locations and ensuring the path to the editor binary path isn't entirely lost in the event 'UnrealEdior' is ever relocated to somewhere else for any arbitrary reason upstream decides.
+# If someone really wants to run Unreal with unmitigated admin privileges, any resulting damage is on YOU and not me.
+# You can still find the binary or modify this script/PKGBUILD yourself.
+# I am *not* going to troubleshoot short-sighted and insecure 'root everything' nonsense.
+# Additionally, I will remind you that "/opt" *is used by default* but the option is, again, ultimately up to the you where the installation resides.
+
if [ "$(id -u)" -eq 0 ]; then
echo "ERROR: Run this as an unprivileged user; not as root."
return;
fi
-if [ -d "${HOME}/.steampath" ] && [ ! -L "${HOME}/.steam/bin" ]; then
+if [ -d "${HOME}/.steam" ] && [ ! -L "${HOME}/.steam/bin" ]; then
ln -s "${HOME}/.steampath" "${HOME}/.steam/bin"
elif [ ! -d "${HOME}/.steampath" ] && [ ! -L "${HOME}/.steam/bin" ]; then
mkdir -p "${HOME}/.steam/bin"
- ln -s "${HOME}/.steampath" "${HOME}/.steam/bin"
+ ln -s "${HOME}/.steam" "${HOME}/.steam/bin"
fi
if [ ! -d "${HOME}/.config/Epic/UnrealEngine/4.27/Intermediate/" ]; then