summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD20
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..acc3d0117342
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = urn-love-git
+ pkgdesc = LÖVE2D bindings for Urn (Lisp->Lua) language
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://gitlab.com/Lignum/urn-love2d-bindings
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = urn-lang-git
+ provides = urn-love
+ source = urn-love-git::git+https://gitlab.com/Lignum/urn-love2d-bindings.git#branch=master
+ md5sums = SKIP
+
+pkgname = urn-love-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a9346e70510
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Manoel Vilela <manoel_vilela [at] engineer [dot] com>
+pkgname=urn-love-git
+pkgver=1.0
+pkgrel=1
+pkgdesc="LÖVE2D bindings for Urn (Lisp->Lua) language"
+arch=('any')
+url="https://gitlab.com/Lignum/urn-love2d-bindings"
+license=('unknown')
+depends=('urn-lang-git')
+makedepends=('git')
+provides=('urn-love')
+source=("urn-love-git::git+https://gitlab.com/Lignum/urn-love2d-bindings.git#branch=master")
+md5sums=('SKIP')
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -dm755 "${pkgdir}/usr/lib/urn/love/"
+ find . -type f \( -iname "*.lisp" -or -iname "*.lua" \) \
+ -exec install -m644 "{}" "${pkgdir}/usr/lib/urn/love/{}" \;
+}