summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD26
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52978ec5a97f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = usb-notify-git
+ pkgdesc = Notification Daemon for usb events
+ pkgver = v0.1.1.r0.gb4d0ffb
+ pkgrel = 1
+ url = https://github.com/userWayneCampbell/usb-notify
+ arch = any
+ license = GPL
+ depends = libnotify
+ source = git+https://github.com/userWayneCampbell/usb-notify.git
+ md5sums = SKIP
+
+pkgname = usb-notify-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf6591a7b18f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Wayne Campbell <wcampbell1995 [at] gmail [dot] com>
+pkgname=usb-notify-git
+_pkgname=usb-notify
+pkgver=v0.1.1.r0.gb4d0ffb
+pkgrel=1
+pkgdesc="Notification Daemon for usb events"
+arch=('any')
+url="https://github.com/userWayneCampbell/usb-notify"
+license=('GPL')
+depends=('libnotify')
+source=("git+https://github.com/userWayneCampbell/usb-notify.git")
+md5sums=('SKIP')
+
+# Support without tags and with tags
+pkgver() {
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make && sudo make install
+}