summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
-rw-r--r--build-fix.patch66
3 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88a7c7d2a604
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = ussp-push
+ pkgdesc = OBEX object pusher for Linux
+ pkgver = 0.11
+ pkgrel = 6
+ url = http://xmailserver.org/ussp-push.html
+ arch = x86_64
+ license = GPL2
+ depends = openobex
+ source = http://xmailserver.org/ussp-push-0.11.tar.gz
+ source = build-fix.patch
+ md5sums = 5c44983ee27809867041feff6bb4423a
+ md5sums = b9020ea9bb34b811206366b407f5e3cd
+
+pkgname = ussp-push
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f10e2bb025e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Giovanni Scafora <linuxmania@gmail.com>
+# Contributor: Alessio 'mOLOk' Bolognino <themolok@gmail.com>
+
+pkgname=ussp-push
+pkgver=0.11
+pkgrel=6
+pkgdesc="OBEX object pusher for Linux"
+arch=('x86_64')
+license=('GPL2')
+url="http://xmailserver.org/ussp-push.html"
+depends=('openobex')
+source=(http://xmailserver.org/$pkgname-$pkgver.tar.gz
+ build-fix.patch)
+md5sums=('5c44983ee27809867041feff6bb4423a'
+ 'b9020ea9bb34b811206366b407f5e3cd')
+
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -p1 <"$srcdir"/build-fix.patch
+}
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+ export LDFLAGS="$LDFLAGS -lopenobex-apps-common"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
diff --git a/build-fix.patch b/build-fix.patch
new file mode 100644
index 000000000000..ae57ca00f1d7
--- /dev/null
+++ b/build-fix.patch
@@ -0,0 +1,66 @@
+diff -dupr ussp-push-0.11.old/src/obex_socket.c ussp-push-0.11/src/obex_socket.c
+--- ussp-push-0.11.old/src/obex_socket.c 2009-05-15 11:03:34.904797689 +0200
++++ ussp-push-0.11/src/obex_socket.c 2009-05-15 11:03:45.599797286 +0200
+@@ -197,7 +197,7 @@ static int bt_sock_name2bth(int devid, c
+ for (i = 0; i < niinf; i++) {
+ char devname[128];
+
+- if (hci_remote_name(dd, &piinf[i].bdaddr, sizeof(devname) - 1,
++ if (hci_read_remote_name(dd, &piinf[i].bdaddr, sizeof(devname) - 1,
+ devname, 100000) >= 0) {
+ if (strcasecmp(devname, btname) == 0) {
+ *btaddr = piinf[i].bdaddr;
+diff -wbBur ussp-push-0.11/src/obex_main.c ussp-push-0.11.q/src/obex_main.c
+--- ussp-push-0.11/src/obex_main.c 2008-08-25 00:48:53.000000000 +0400
++++ ussp-push-0.11.q/src/obex_main.c 2013-05-27 14:13:06.533474671 +0400
+@@ -85,41 +85,6 @@
+ int bt_debug;
+
+
+-
+-/*
+- * These two functions are from affix/profiles/obex/obex_io.c
+- */
+-int get_filesize(const char *filename)
+-{
+- struct stat stats;
+-
+- stat(filename, &stats);
+- return (int) stats.st_size;
+-}
+-
+-uint8_t *easy_readfile(const char *filename, int *file_size)
+-{
+- int actual;
+- int fd;
+- uint8_t *buf;
+-
+- fd = open(filename, O_RDONLY, 0);
+- if (fd == -1) {
+- return NULL;
+- }
+- *file_size = get_filesize(filename);
+- printf("name=%s, size=%d\n", filename, *file_size);
+- if (!(buf = malloc(*file_size))) {
+- return NULL;
+- }
+-
+- actual = read(fd, buf, *file_size);
+- close(fd);
+-
+- *file_size = actual;
+- return buf;
+-}
+-
+ /*
+ * This function comes from affix/profiles/obex/obex_client.c .. All I changed
+ * was a BTERROR() macro. The OBEX_HandleInput() calls inside the loop should
+@@ -197,7 +197,7 @@
+ *err = -1;
+ return NULL;
+ }
+- if (!(handle = OBEX_Init(OBEX_TRANS_CUST, obex_event, 0))) {
++ if (!(handle = OBEX_Init(OBEX_TRANS_CUSTOM, obex_event, 0))) {
+ BTERROR("OBEX_Init failed: %s\n", strerror(errno));
+ obex_free(gt);
+ *err = -1;