summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD23
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02e08073ad21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = utf8.h
+ pkgdesc = Simple one header solution to supporting utf8 strings in C and C++
+ pkgver = r199.ce48f0e
+ pkgrel = 1
+ url = https://github.com/sheredom/utf8.h
+ arch = any
+ license = Unlicense
+ makedepends = git
+ source = git+https://github.com/sheredom/utf8.h.git
+ sha1sums = SKIP
+
+pkgname = utf8.h
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96759758a6b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: piernov <piernov@piernov.org>
+
+pkgname=utf8.h
+pkgver=r199.ce48f0e
+pkgrel=1
+pkgdesc='Simple one header solution to supporting utf8 strings in C and C++'
+license=('Unlicense')
+arch=('any')
+url='https://github.com/sheredom/utf8.h'
+makedepends=('git')
+source=("git+https://github.com/sheredom/utf8.h.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname}"
+ install -dm 755 "${pkgdir}/usr/include/utf8"
+ install -D -m 644 "utf8.h" "${pkgdir}/usr/include/utf8"
+}