summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD47
-rw-r--r--archlinux.ini5
-rw-r--r--uwsgi_trick_chroot.patch16
4 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75bd368018e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = uwsgi-plugin-php71
+ pkgdesc = Plugin for PHP 7.1 support
+ pkgver = 2.0.17
+ pkgrel = 1
+ url = http://projects.unbit.it/
+ arch = x86_64
+ license = GPL2
+ makedepends = python2
+ depends = uwsgi
+ depends = php71-embed
+ depends = libyaml
+ depends = jansson
+ source = https://projects.unbit.it/downloads/uwsgi-2.0.17.tar.gz
+ source = uwsgiplugin.py::https://raw.githubusercontent.com/unbit/uwsgi/9787f6882c2475aa9873e400988160b17dd04545/plugins/systemd_logger/uwsgiplugin.py
+ source = archlinux.ini
+ source = uwsgi_trick_chroot.patch
+ sha1sums = cfa2e072f290f63bad235fc6fc92a8f5c27f1ab5
+ sha1sums = 4f89e407fd95ee740764ec3623a4b07977f96d9b
+ sha1sums = 5d20faadab172ed2f03adc35e2e8062c4a1488f5
+ sha1sums = 5a9b549a42e2ad2b45edd3eab9fd359919df6ce9
+
+pkgname = uwsgi-plugin-php71
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff8342a50787
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
+# Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
+# Contributor: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Valentin Hăloiu <vially.ichb+aur@gmail.com>
+# Contributor: Angel Velasquez <angvp@archlinux.org>
+# Contributor: Kevin Zuber <uKev@knet.eu>
+# Contributor: Vsevolod Balashov <vsevolod@balashov.name>
+# Contributor: David Runge <dave@sleepmap.de>
+
+pkgname=uwsgi-plugin-php71
+pkgdesc="Plugin for PHP 7.1 support"
+pkgver=2.0.17
+pkgrel=1
+arch=(x86_64)
+url="http://projects.unbit.it/$pkgbase"
+license=(GPL2)
+depends=(uwsgi php71-embed libyaml jansson)
+makedepends=(python2)
+source=(
+ "https://projects.unbit.it/downloads/uwsgi-$pkgver.tar.gz"
+ uwsgiplugin.py::https://raw.githubusercontent.com/unbit/uwsgi/9787f6882c2475aa9873e400988160b17dd04545/plugins/systemd_logger/uwsgiplugin.py
+ archlinux.ini
+ uwsgi_trick_chroot.patch
+)
+sha1sums=(
+ 'cfa2e072f290f63bad235fc6fc92a8f5c27f1ab5'
+ '4f89e407fd95ee740764ec3623a4b07977f96d9b'
+ '5d20faadab172ed2f03adc35e2e8062c4a1488f5'
+ '5a9b549a42e2ad2b45edd3eab9fd359919df6ce9'
+)
+
+prepare() {
+ cd "$srcdir/uwsgi-$pkgver"
+ cp "$srcdir/archlinux.ini" buildconf/archlinux.ini
+ patch -Np1 -i $srcdir/uwsgi_trick_chroot.patch
+
+ cp $srcdir/uwsgiplugin.py plugins/systemd_logger/uwsgiplugin.py
+}
+
+build() {
+ cd "$srcdir/uwsgi-$pkgver"
+ UWSGICONFIG_PHPDIR=/opt/php71/usr python2 uwsgiconfig.py --plugin plugins/php archlinux php71
+}
+
+package() {
+ install -Dm 755 "$srcdir/uwsgi-$pkgver/php71_plugin.so" "$pkgdir/usr/lib/uwsgi/php71_plugin.so"
+}
diff --git a/archlinux.ini b/archlinux.ini
new file mode 100644
index 000000000000..e145c48a6b5d
--- /dev/null
+++ b/archlinux.ini
@@ -0,0 +1,5 @@
+[uwsgi]
+plugin_dir = /usr/lib/uwsgi
+plugins = rack, rbthreads, fiber, psgi, lua, php, jvm, mono, cgi, webdav
+main_plugin = systemd_logger,pam
+inherit = base
diff --git a/uwsgi_trick_chroot.patch b/uwsgi_trick_chroot.patch
new file mode 100644
index 000000000000..663bba76b82d
--- /dev/null
+++ b/uwsgi_trick_chroot.patch
@@ -0,0 +1,16 @@
+diff --git a/uwsgiconfig.py b/uwsgiconfig.py
+index e447123..4d55f2c 100644
+--- a/uwsgiconfig.py
++++ b/uwsgiconfig.py
+@@ -1129,10 +1129,7 @@ def build_plugin(path, uc, cflags, ldflags, libs, name = None):
+ except:
+ pass
+
+- if uc:
+- plugin_dest = uc.get('plugin_build_dir', uc.get('plugin_dir')) + '/' + name + '_plugin'
+- else:
+- plugin_dest = name + '_plugin'
++ plugin_dest = name + '_plugin'
+
+ shared_flag = '-shared'
+