summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
-rw-r--r--V2C.desktop11
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58df03e4af70
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = v2c
+ pkgdesc = A 2channel and Twitter browser that made from Java+Swing
+ pkgver = 2.11.4
+ pkgrel = 2
+ url = http://v2c.s50.xrea.com
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = java-environment
+ source = http://v2c.s50.xrea.com/V2C_2.11.4.tar.gz
+ source = V2C.desktop
+ md5sums = 7e8915c4052eae46ffbee572b641deac
+ md5sums = 148b6340aa6345b42ad0425c2d8fb6b6
+
+pkgname = v2c
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d29a6a65c55f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: orumin <dev@orum.in>
+
+pkgname=v2c
+pkgver=2.11.4
+pkgrel=2
+pkgdesc="A 2channel and Twitter browser that made from Java+Swing"
+arch=('i686' 'x86_64')
+url="http://v2c.s50.xrea.com"
+license=('custom')
+depends=('java-environment')
+source=(http://v2c.s50.xrea.com/V2C_${pkgver}.tar.gz
+V2C.desktop)
+md5sums=('7e8915c4052eae46ffbee572b641deac'
+ '148b6340aa6345b42ad0425c2d8fb6b6')
+
+package() {
+ mkdir "${pkgdir}/opt"
+ cp -r "${srcdir}/${pkgname}" "${pkgdir}/opt"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ cp "${srcdir}/${pkgname}/v2c" "${pkgdir}/usr/bin"
+ cat <<'EOF' > "${pkgdir}/usr/bin/v2c"
+#!/bin/sh
+cd /opt/v2c/
+./v2c $@
+EOF
+
+ mkdir -p "${pkgdir}/usr/share/applications"
+ cp "${srcdir}/V2C.desktop" "${pkgdir}/usr/share/applications"
+
+ chmod a+x "${pkgdir}/usr/bin/v2c"
+ chmod a+x "${pkgdir}/opt/${pkgname}/v2c"
+ chmod a+w "${pkgdir}/opt/${pkgname}"
+ chmod a+w "${pkgdir}/opt/${pkgname}/launcher"
+}
diff --git a/V2C.desktop b/V2C.desktop
new file mode 100644
index 000000000000..24510b667856
--- /dev/null
+++ b/V2C.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=V2C
+GenericName=BBS Browser
+Comment=Viewer/Writer for BBS like 2ch
+Icon=/opt/v2c/v2cicon.png
+Exec=/opt/v2c/v2c
+Terminal=0
+Type=Application
+Categories=Application;Network;Java;