summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae11e951850b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Dec 7 02:33:31 UTC 2015
+pkgbase = vanfanel-sdl-rbp-git
+ pkgdesc = Vanfanel's SDL 1.2.15 fork that includes a better RaspberryPi native 2D API driver for optimal performance and visuals
+ pkgver = 12.5e5cf17
+ pkgrel = 1
+ url = https://github.com/vanfanel/SDL-1.2.15-raspberrypi
+ arch = armv7h
+ license = GPL
+ depends = raspberrypi-firmware-tools
+ depends = bash
+ provides = sdl
+ conflicts = sdl
+ source = git+https://github.com/vanfanel/SDL-1.2.15-raspberrypi.git
+ md5sums = SKIP
+
+pkgname = vanfanel-sdl-rbp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..15762e7a4c29
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Chris Simpson <csimpson.aur at gmail dot com>
+
+pkgname=vanfanel-sdl-rbp-git
+pkgver=12.5e5cf17
+pkgrel=1
+pkgdesc="Vanfanel's SDL 1.2.15 fork that includes a better RaspberryPi native 2D API driver for optimal performance and visuals"
+arch=('armv7h')
+url="https://github.com/vanfanel/SDL-1.2.15-raspberrypi"
+license=('GPL')
+depends=(raspberrypi-firmware-tools bash)
+makedepends=()
+provides=('sdl')
+conflicts=('sdl')
+
+source=("git+https://github.com/vanfanel/SDL-1.2.15-raspberrypi.git")
+md5sums=('SKIP')
+
+_gitname=SDL-1.2.15-raspberrypi
+
+pkgver() {
+ cd $_gitname
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$_gitname"
+ ./MAC_ConfigureSDL12-rpi2.sh
+ make
+}
+
+package()
+{
+ cd "$_gitname"
+ make DESTDIR="$pkgdir/" install
+}