summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac00d47758c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vapoursynth-plugin-adaptive-binarize-git
+ pkgdesc = Plugin for Vapoursynth: adaptive-binarize (GIT version)
+ pkgver = r1.3.g655014b
+ pkgrel = 1
+ url = https://github.com/dnjulek/VapourSynth-AdaptiveBinarize.git
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = gcc
+ makedepends = binutils
+ makedepends = pkgconf
+ depends = vapoursynth
+ provides = vapoursynth-plugin-adaptive-binarize
+ conflicts = vapoursynth-plugin-adaptive-binarize
+ source = adaptive-binarize::git+https://github.com/dnjulek/VapourSynth-AdaptiveBinarize.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-adaptive-binarize-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ecffba2fc8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: cnf3rd <subs.in.tokyo@gmail.com>
+
+_plug=adaptive-binarize
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r1.3.g655014b
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://github.com/dnjulek/VapourSynth-AdaptiveBinarize.git'
+license=('GPL')
+depends=(
+ 'vapoursynth'
+)
+makedepends=(
+ 'git'
+ 'gcc'
+ 'binutils'
+ 'pkgconf'
+)
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/dnjulek/VapourSynth-AdaptiveBinarize.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
+}
+
+build() {
+ cd "${_plug}"
+ gcc -shared $(pkg-config vapoursynth --cflags) src/adaptivebinarize.cpp $(pkg-config vapoursynth --libs) -O3 -o lib${_plug}.so
+ strip lib${_plug}.so
+}
+
+package() {
+ cd "${_plug}"
+
+ install -Dm755 lib${_plug}.so ${pkgdir}/usr/lib/vapoursynth/plugins/lib${_plug}.so
+}