summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD42
2 files changed, 25 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c3f695316d19..04d19bd33e22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vapoursynth-plugin-eedi3m-git
pkgdesc = Plugin for Vapoursynth: eedi3m (GIT version)
pkgver = 4.7.gd11bdb3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/HomeOfVapourSynthEvolution/VapourSynth-EEDI3
arch = x86_64
license = GPL2
@@ -10,7 +10,10 @@ pkgbase = vapoursynth-plugin-eedi3m-git
makedepends = boost
makedepends = meson
depends = vapoursynth
+ depends = gcc-libs
+ depends = glibc
depends = opencl-icd-loader
+ depends = boost-libs
depends = libboost_filesystem.so
provides = vapoursynth-plugin-eedi3m
conflicts = vapoursynth-plugin-eedi3m
diff --git a/PKGBUILD b/PKGBUILD
index 3a8558e3e34a..fd4d3adbd90c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,29 @@
_plug=eedi3m
pkgname=vapoursynth-plugin-${_plug}-git
pkgver=4.7.gd11bdb3
-pkgrel=2
+pkgrel=3
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://github.com/HomeOfVapourSynthEvolution/VapourSynth-EEDI3'
license=('GPL2')
-depends=('vapoursynth'
- 'opencl-icd-loader'
- 'libboost_filesystem.so'
- )
-makedepends=('git'
- 'opencl-headers'
- 'boost'
- 'meson'
- )
+depends=(
+ 'vapoursynth'
+ 'gcc-libs' # libgcc_s.so libstdc++.so
+ 'glibc' # libc.so
+ 'opencl-icd-loader' # libOpenCL.so
+ 'boost-libs' 'libboost_filesystem.so'
+)
+makedepends=(
+ 'git'
+ 'opencl-headers'
+ 'boost'
+ 'meson'
+)
provides=("vapoursynth-plugin-${_plug}")
-conflicts=("vapoursynth-plugin-${_plug}"
- 'vapoursynth-plugin-eedi3cl-git'
- )
+conflicts=(
+ "vapoursynth-plugin-${_plug}"
+ 'vapoursynth-plugin-eedi3cl-git'
+)
source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-EEDI3.git")
sha256sums=('SKIP')
options=('debug')
@@ -30,21 +35,16 @@ pkgver() {
echo "$(git describe --long --tags | tr - . | tr -d r)"
}
-prepare() {
- mkdir -p build
-}
-
build() {
- cd build
- arch-meson "../${_plug}" \
+ arch-meson "${_plug}" build \
--buildtype=release \
--libdir /usr/lib/vapoursynth
- ninja
+ meson compile -C build
}
package(){
- DESTDIR="${pkgdir}" ninja -C build install
+ DESTDIR="${pkgdir}" meson install -C build
install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}