summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rwxr-xr-xPKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec97b0ecb8c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vapoursynth-plugin-f3kdb
+ pkgdesc = flash3kyuu deband plugin for VapourSynth
+ pkgver = 2.0.0
+ pkgrel = 1
+ url = https://github.com/SAPikachu/flash3kyuu_deband
+ arch = x86_64
+ license = GPL3
+ depends = gcc-libs
+ depends = glibc
+ depends = vapoursynth
+ source = vapoursynth-plugin-f3kdb-2.0.0.tar.gz::https://github.com/SAPikachu/flash3kyuu_deband/archive/2.0.0-1.tar.gz
+ md5sums = a18d2c87439fdf0aa21dd01ab5dfbb59
+
+pkgname = vapoursynth-plugin-f3kdb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..03a9e98ecf5a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=vapoursynth-plugin-f3kdb
+pkgver=2.0.0
+pkgrel=1
+pkgdesc='flash3kyuu deband plugin for VapourSynth'
+arch=('x86_64')
+url='https://github.com/SAPikachu/flash3kyuu_deband'
+license=('GPL3')
+depends=('gcc-libs' 'glibc' 'vapoursynth')
+source=("vapoursynth-plugin-f3kdb-${pkgver}.tar.gz::https://github.com/SAPikachu/flash3kyuu_deband/archive/${pkgver}-1.tar.gz")
+md5sums=('a18d2c87439fdf0aa21dd01ab5dfbb59')
+
+build() {
+ cd flash3kyuu_deband-${pkgver}-1
+
+ ./waf configure \
+ --prefix='/usr' \
+ --libdir='/usr/lib/vapoursynth'
+ ./waf build
+}
+
+package() {
+ cd flash3kyuu_deband-${pkgver}-1
+
+ ./waf install \
+ --destdir="${pkgdir}" \
+ --no-ldconfig
+}
+
+# vim: ts=2 sw=2 et: