summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fbcd3a1f0fd0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-vivtc-git
+ pkgdesc = Plugin for Vapoursynth: vivtc (GIT version)
+ pkgver = R1.2.ged56d96
+ pkgrel = 1
+ url = https://github.com/vapoursynth/vivtc
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ depends = vapoursynth
+ provides = vapoursynth-plugin-vivtc
+ conflicts = vapoursynth-plugin-vivtc
+ source = vivtc::git+https://github.com/vapoursynth/vivtc.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-vivtc-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd3d2e31b723
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Joshua Holmer <jholmer.in@gmail.com>
+
+_plug=vivtc
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=R1.2.ged56d96
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://github.com/vapoursynth/vivtc'
+license=('MIT')
+depends=('vapoursynth')
+makedepends=('git'
+ 'meson'
+)
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/vapoursynth/vivtc.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ arch-meson "../${_plug}" --libdir /usr/lib/vapoursynth
+ ninja
+}
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+
+ install -Dm644 "${_plug}/docs/vivtc.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.rst"
+}