summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 51aafc558203..49ba2b5b04e1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,8 +15,11 @@ pkgbase = vapoursynth-plugin-vsdpir-git
depends = python-numpy
depends = python-tqdm
depends = python-requests
- optdepends = python-pytorch: pytorch CPU with AVX2 optimizations
- optdepends = python-pytorch-cuda: pytorch CUDA with CPU with AVX2 optimizations
+ optdepends = python-pytorch: CPU
+ optdepends = python-pytorch-cuda: CPU and CUDA
+ optdepends = python-pytorch-opt: CPU with AVX2 CPU optimizations)
+ optdepends = python-pytorch-opt-cuda: GPU CUDA and AVX2 CPU optimizations
+ optdepends = python-pytorch-opt-rocm: GPU ROCm and AVX2 CPU optimizations
optdepends = python-onnxruntime: ONNXRuntime support
provides = vapoursynth-plugin-vsdpir
conflicts = vapoursynth-plugin-vsdpir
diff --git a/PKGBUILD b/PKGBUILD
index 5225fedfdf87..6aeda1fc0bd1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,8 +23,11 @@ makedepends=(
'python-hatchling'
)
optdepends=(
- 'python-pytorch: pytorch CPU with AVX2 optimizations'
- 'python-pytorch-cuda: pytorch CUDA with CPU with AVX2 optimizations'
+ 'python-pytorch: CPU'
+ 'python-pytorch-cuda: CPU and CUDA'
+ 'python-pytorch-opt: CPU with AVX2 CPU optimizations)'
+ 'python-pytorch-opt-cuda: GPU CUDA and AVX2 CPU optimizations'
+ 'python-pytorch-opt-rocm: GPU ROCm and AVX2 CPU optimizations'
'python-onnxruntime: ONNXRuntime support'
)
provides=("vapoursynth-plugin-${_plug}")