summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD22
2 files changed, 25 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 251705b99b43..c81be41a5bd5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sat Feb 20 21:02:41 UTC 2016
pkgbase = varrick-git
pkgdesc = A convenient template engine to just 'Do the thing!'
- pkgver = 0.2.0.r10.g9934958
+ pkgver = 0.2.0.r33.gd1553d7
pkgrel = 1
url = https://github.com/ztombol/varrick
arch = any
@@ -13,6 +15,10 @@ pkgbase = varrick-git
provides = varrick
conflicts = varrick
source = varrick::git+https://github.com/ztombol/varrick
+ source = git+https://github.com/ztombol/bats-core
+ source = git+https://github.com/ztombol/bats-assert
+ sha512sums = SKIP
+ sha512sums = SKIP
sha512sums = SKIP
pkgname = varrick-git
diff --git a/PKGBUILD b/PKGBUILD
index 549122d9bc4f..fc76c02b87f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Zoltan Tombol <zoltan (dot) tombol (plus) aur (at) gmail (dot) com>
pkgname=varrick-git
-pkgver=0.2.0.r10.g9934958
+pkgver=0.2.0.r33.gd1553d7
pkgrel=1
pkgdesc="A convenient template engine to just 'Do the thing!'"
arch=(any)
@@ -12,12 +12,26 @@ makedepends=('git' 'ruby-ronn')
checkdepends=('bats-git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("${pkgname%-git}::git+https://github.com/ztombol/${pkgname%-git}")
-sha512sums=('SKIP')
+source=("${pkgname%-git}::git+https://github.com/ztombol/${pkgname%-git}"
+ "git+https://github.com/ztombol/bats-core"
+ "git+https://github.com/ztombol/bats-assert")
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd "${srcdir}/${pkgname%-git}"
- printf "%s" "$(git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g')"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname%-git}"
+ git submodule init
+ git config submodule.test/test_helper/bats-core.url \
+ "${srcdir}/bats-core"
+ git config submodule.test/test_helper/bats-assert.url \
+ "${srcdir}/bats-assert"
+ git submodule update
}
build() {