summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
2 files changed, 25 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39ea4814387e..1902bd688fca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vcmi-git
pkgdesc = Open-source engine for Heroes of Might and Magic III
- pkgver = 1.4.4.150.ge9aa95254
+ pkgver = 1.4.5.1132.g0e36b9651
pkgrel = 1
url = http://vcmi.eu
install = vcmi-git.install
@@ -14,6 +14,7 @@ pkgbase = vcmi-git
makedepends = boost
makedepends = cmake
makedepends = git
+ makedepends = qt5-tools
depends = boost-libs
depends = ffmpeg
depends = sdl2_image
@@ -25,7 +26,6 @@ pkgbase = vcmi-git
depends = gtk-update-icon-cache
depends = hicolor-icon-theme
depends = tbb
- depends = fuzzylite
depends = luajit
optdepends = innoextract: required by vcmibuilder
optdepends = unshield: required by vcmibuilder
@@ -33,6 +33,10 @@ pkgbase = vcmi-git
provides = vcmi
conflicts = vcmi
source = vcmi-git::git+https://github.com/vcmi/vcmi.git#branch=develop
+ source = git+https://github.com/vcmi/innoextract.git#branch=vcmi
+ source = git+https://github.com/fuzzylite/fuzzylite.git#branch=release
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
pkgname = vcmi-git
diff --git a/PKGBUILD b/PKGBUILD
index 9a758cd090d0..00f597ceb0ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,42 @@
# Contributor: Raziel23 <venom23 at runbox dot com>
pkgname=vcmi-git
-pkgver=1.4.4.150.ge9aa95254
+pkgver=1.4.5.1132.g0e36b9651
pkgrel=1
pkgdesc="Open-source engine for Heroes of Might and Magic III"
arch=('i686' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
url="http://vcmi.eu"
license=('GPL2')
-depends=('boost-libs' 'ffmpeg' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf' 'qt5-base' 'libxkbcommon-x11'
- 'desktop-file-utils' 'gtk-update-icon-cache' 'hicolor-icon-theme' 'tbb' 'fuzzylite'
- 'luajit')
-makedepends=('boost' 'cmake' 'git')
+depends=('boost-libs' 'ffmpeg' 'sdl2_image' 'sdl2_mixer' 'sdl2_ttf' 'qt5-base'
+ 'libxkbcommon-x11' 'desktop-file-utils' 'gtk-update-icon-cache'
+ 'hicolor-icon-theme' 'tbb' 'luajit')
+makedepends=('boost' 'cmake' 'git' 'qt5-tools')
optdepends=('innoextract: required by vcmibuilder'
'unshield: required by vcmibuilder'
'unzip: required by vcmibuilder')
provides=('vcmi')
conflicts=('vcmi')
install="${pkgname}.install"
-source=("${pkgname}::git+https://github.com/vcmi/vcmi.git#branch=develop")
-md5sums=('SKIP')
+source=("${pkgname}::git+https://github.com/vcmi/vcmi.git#branch=develop"
+ git+https://github.com/vcmi/innoextract.git#branch=vcmi
+ git+https://github.com/fuzzylite/fuzzylite.git#branch=release
+)
+md5sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "${pkgname}"
git describe --tags | tr - .
}
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ echo "${srcdir}"
+ git submodule init
+ git config submodule.innoextract.url "${srcdir}/innoextract"
+ git config submodule.AI/FuzzyLite.url "${srcdir}/fuzzylite"
+ git -c protocol.file.allow=always submodule update
+}
+
build() {
cd "${srcdir}/${pkgname}"
mkdir -p build && cd build