summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x[-rw-r--r--]Changelog2
-rwxr-xr-x[-rw-r--r--]PKGBUILD66
-rwxr-xr-x[-rw-r--r--]vertcoin-qt.appdata.xml9
3 files changed, 51 insertions, 26 deletions
diff --git a/Changelog b/Changelog
index ecdbcbb4e3b6..8c9c81deb60d 100644..100755
--- a/Changelog
+++ b/Changelog
@@ -1 +1 @@
-https://github.com/vertcoin-project/vertcoin-core/blob/master/doc/release-notes.md \ No newline at end of file
+https://github.com/vertcoin-project/vertcoin-core/blob/22.x/doc/release-notes.md
diff --git a/PKGBUILD b/PKGBUILD
index b6bcd6dd7a84..05cc29438dfc 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,53 @@
# Maintainer: vertion <vertion@protonmail.com>
pkgbase=vertcoin
-pkgname=('vertcoin-daemon' 'vertcoin-cli' 'vertcoin-qt' 'vertcoin-tx')
-pkgver=0.18.0
+pkgname=('vertcoin-daemon' 'vertcoin-cli' 'vertcoin-qt' 'vertcoin-tx' 'vertcoin-wallet' 'vertcoin-util')
+pkgver=22.1
pkgrel=1
arch=('x86_64')
url="https://www.vertcoin.org/"
-makedepends=('boost' 'libevent' 'qt5-base' 'qt5-tools' 'qrencode' 'miniupnpc' 'protobuf' 'zeromq' 'gmp')
+makedepends=('boost' 'libevent' 'qt5-base' 'qt5-tools' 'qrencode' 'miniupnpc' 'protobuf' 'zeromq' 'gmp' 'db5.3')
license=('MIT')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/vertcoin-project/vertcoin-core/archive/refs/tags/$pkgver.tar.gz"
-
+source=("$pkgname-$pkgver.tar.gz::https://github.com/vertcoin-project/vertcoin-core/releases/download/v$pkgver/vertcoin-$pkgver.tar.gz"
+ "$pkgbase-$pkgver.SHA256SUMS::https://github.com/vertcoin-project/vertcoin-core/releases/download/v$pkgver/SHA256SUMS"
+ "$pkgbase-$pkgver.SHA256SUMS.asc::https://github.com/vertcoin-project/vertcoin-core/releases/download/v$pkgver/SHA256SUMS.asc"
"vertcoin.sysusers"
"vertcoin.tmpfiles"
"vertcoin-qt.desktop"
"vertcoin-qt.appdata.xml")
-sha256sums=('c49c477b214fe4b47ba17861a9305aca15074554170599811332372a334a60b5'
+sha256sums=('601d0b6370198c718f102d4c96768c9df668b140aea8def38f4a23bc3afe55af'
+ 'a36af7726ae9991aaf50fb71b9e1912f91de28c17328db89b15a4e573f72a819'
+ 'SKIP'
'3cd12f27d9af2957cdb163518869de5d162da1247f7677f185c9d70d38882ace'
'a86e6169531e7cc1dbec67d448c48d586ca97616078d0ce1d0e72ee5c38f2997'
'b303f138e0d86d9819432a3559bb5397e41ca79a08fa5677a09cfbb15cb85165'
- 'e6894e103f6f438070723a592cd7a905ec304aaa3592fe2aad72e9eb6cd618d5')
-b2sums=('762ad7095c8a297a6becfa834f89de8ea2ab52701c4b3d941335234465b737cab69420ff7c2e0326432d7056983fb84873be9a59de698c3f8c9231390c8c7f78'
+ 'd399c2dc411b9978f4d815cfe97ce1c4152bb522135cd00ac8e322655accff94')
+b2sums=('4476d3517b556335b13cb8c8fa857a4742b5f68897ad049ef0b55a2333fb03008f3e55e2c6401c6f90b1dab0e54dfbd2189b81f938cbde078d3c6966d341d0b8'
+ '91c060e6f91f040c79e59949687cc2b83c682436df5fbfa3cfbc886d8afb6d48aca4827ed9af061abf2c95d7f9eebf983aaf584ad42c666479cb7ec42ccdd4ef'
+ 'SKIP'
'257f2d33148559afd622e597b1398c94447f432527bb79776e716944fd2de21f8909d421ddca25f9ae758ccb759d60db91186215f852ac8fc660d49edf2a5d77'
'38b97d6e7f064af6ad2bef56b87f7067805db921d5a651f04cae255778eecfbf96cf9f439318be10853666e609ff49dc7004be90bc6a774dad36351e75c96971'
'98feb764243fd3fd6d899dd7d9429996cb3c346cff9f4dcbafd609e68714973a4e78ab3dd1e7e66b81ab73c1a35277fcf1ae6b5cbea5288480b48438c47646fc'
- '8671f280b84b092c9c5d2011fdad646130c4c03cf3c67da5a70025e8646ce5f268884307f1b9d4a4652227a448ee50c59757391d81be698f8912e1a45350c285')
+ 'e9165e966dcbb5ccbb6ce4a4a7e5d1bcae65a707f2310560aad4d57fdcabda723c84c53fee3fe56a4ce2c7b7a74f2fa9cd1b088edf5385a663f9a54f78816443')
validpgpkeys=(28E72909F1717FE9607754F8A7BEB2621678D37D)
changelog=Changelog
prepare() {
- cd "$pkgbase-core-$pkgver"
+ cd "$pkgbase-$pkgver"
autoreconf -fi
}
build() {
- cd $pkgbase-core-$pkgver
- ./configure --prefix=/usr --with-gui=qt5 --with-incompatible-bdb --disable-tests --disable-bench --disable-dependency-tracking
+ cd $pkgbase-$pkgver
+ ./configure --prefix=/usr --with-gui=qt5 --with-incompatible-bdb --disable-tests --disable-bench BDB_LIBS="-ldb_cxx-5.3" BDB_CFLAGS="-I/usr/include/db5.3"
make
}
package_vertcoin-qt() {
pkgdesc="Vertcoin is a peer-to-peer network based digital currency - Qt"
- depends=(boost-libs libevent qt5-base miniupnpc libminiupnpc.so qrencode protobuf zeromq hicolor-icon-theme db gmp)
+ depends=(boost-libs libevent qt5-base miniupnpc libminiupnpc.so qrencode protobuf zeromq hicolor-icon-theme db5.3 gmp)
- cd $pkgbase-core-$pkgver
+ cd $pkgbase-$pkgver
install -Dm755 src/qt/vertcoin-qt "$pkgdir"/usr/bin/vertcoin-qt
install -Dm644 doc/man/vertcoin-qt.1 \
"$pkgdir"/usr/share/man/man1/vertcoin-qt.1
@@ -63,10 +68,10 @@ package_vertcoin-qt() {
package_vertcoin-daemon() {
pkgdesc="Vertcoin is a peer-to-peer network based digital currency - daemon"
- depends=(boost-libs db libevent miniupnpc libminiupnpc.so sqlite zeromq gmp)
+ depends=(boost-libs db5.3 libevent miniupnpc libminiupnpc.so sqlite zeromq gmp)
backup=('etc/vertcoin/vertcoin.conf')
- cd $pkgbase-core-$pkgver
+ cd $pkgbase-$pkgver
install -Dm755 src/vertcoind "$pkgdir"/usr/bin/vertcoind
install -Dm644 contrib/bitcoind.bash-completion \
"$pkgdir"/usr/share/bash-completion/completions/vertcoind
@@ -76,7 +81,6 @@ package_vertcoin-daemon() {
"$pkgdir/usr/lib/sysusers.d/vertcoin.conf"
install -Dm644 "$srcdir/vertcoin.tmpfiles" \
"$pkgdir/usr/lib/tmpfiles.d/vertcoin.conf"
- mv share/examples/bitcoin.conf share/examples/vertcoin.conf
install -Dm644 share/examples/vertcoin.conf \
"$pkgdir/etc/vertcoin/vertcoin.conf"
@@ -87,7 +91,7 @@ package_vertcoin-cli() {
pkgdesc="Vertcoin is a peer-to-peer network based digital currency - RPC client"
depends=(boost-libs libevent)
- cd $pkgbase-core-$pkgver
+ cd $pkgbase-$pkgver
install -Dm755 src/vertcoin-cli "$pkgdir"/usr/bin/vertcoin-cli
install -Dm644 contrib/bitcoin-cli.bash-completion \
"$pkgdir"/usr/share/bash-completion/completions/vertcoin-cli
@@ -101,7 +105,7 @@ package_vertcoin-tx() {
pkgdesc="Vertcoin is a peer-to-peer network based digital currency - Transaction tool"
depends=(boost-libs openssl)
- cd $pkgbase-core-$pkgver
+ cd $pkgbase-$pkgver
install -Dm755 src/vertcoin-tx "$pkgdir"/usr/bin/vertcoin-tx
install -Dm644 contrib/bitcoin-tx.bash-completion \
"$pkgdir"/usr/share/bash-completion/completions/vertcoin-tx
@@ -110,3 +114,27 @@ package_vertcoin-tx() {
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
+
+package_vertcoin-wallet() {
+ pkgdesc="Vertcoin is a peer-to-peer network based digital currency - Wallet tool"
+ depends=(boost-libs openssl libevent)
+
+ cd $pkgbase-$pkgver
+ install -Dm755 src/vertcoin-wallet "$pkgdir"/usr/bin/vertcoin-wallet
+ install -Dm644 doc/man/vertcoin-wallet.1 \
+ "$pkgdir"/usr/share/man/man1/vertcoin-wallet.1
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
+
+package_vertcoin-util() {
+ pkgdesc="Vertcoin is a peer-to-peer network based digital currency - Util tool"
+ depends=(boost-libs openssl libevent)
+
+ cd $pkgbase-$pkgver
+ install -Dm755 src/vertcoin-util "$pkgdir"/usr/bin/vertcoin-util
+ install -Dm644 doc/man/vertcoin-util.1 \
+ "$pkgdir"/usr/share/man/man1/vertcoin-util.1
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+}
diff --git a/vertcoin-qt.appdata.xml b/vertcoin-qt.appdata.xml
index 2836e9c7c7cf..2c1c571ec5d0 100644..100755
--- a/vertcoin-qt.appdata.xml
+++ b/vertcoin-qt.appdata.xml
@@ -9,12 +9,9 @@
<url type="bugtracker">https://github.com/vertcoin-project/vertcoin-core/issues</url>
<launchable type="desktop-id">vertcoin-qt.desktop</launchable>
<description>
- <p>Vertcoin is an experimental digital currency that enables instant
- payments to anyone, anywhere in the world. Vertcoin uses
- peer-to-peer technology to operate with no central authority:
- managing transactions and issuing money are carried out
- collectively by the network. Vertcoin Core is the name of open
- source software which enables the use of this currency.</p>
+ <p> Vertcoin Core connects to the Vertcoin peer-to-peer network to download and
+ fully validate blocks and transactions. It also includes a wallet and
+ graphical user interface.</p>
</description>
<screenshots>
<screenshot>