summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD46
-rw-r--r--vesc_tool.pro107
3 files changed, 144 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3547e8f538c..d7c7a7db4a8b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,24 @@
pkgbase = vesc_tool-git
pkgdesc = VESC ESC graphical configuration tool
- pkgver = r157.6f378c1
+ pkgver = 2.03
pkgrel = 1
- url = https://vesc-project.com/
- arch = any
- license = GPL
+ url = https://vesc-project.com/vesc_tool
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ arch = armv6h
+ license = GPL3
makedepends = git
+ depends = qt5-base
depends = qt5-connectivity
- depends = qt5-serialport
depends = qt5-quickcontrols2
- provides = vesc_tool-git
- conflicts = vesc_tool-git
- source = git+https://github.com/vedderb/vesc_tool.git
- md5sums = SKIP
+ depends = qt5-serialport
+ depends = qt5-location
+ source = vesc_tool-git::git+https://github.com/vedderb/vesc_tool.git
+ source = vesc_tool.pro
+ sha256sums = SKIP
+ sha256sums = fb9eb66d9ef00606f61754a7efa8dbab18dff810c674a106e2e770e62899be68
pkgname = vesc_tool-git
diff --git a/PKGBUILD b/PKGBUILD
index c6c7f32e0bf3..6621df8c1c96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,37 @@
pkgname=vesc_tool-git
-pkgver=r157.6f378c1
+pkgver=2.03
pkgrel=1
pkgdesc="VESC ESC graphical configuration tool"
-arch=('any')
-url="https://vesc-project.com/"
-license=('GPL')
-groups=()
-depends=("qt5-connectivity" "qt5-serialport" "qt5-quickcontrols2")
+arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
+url="https://vesc-project.com/vesc_tool"
+license=('GPL3')
+depends=('qt5-base' 'qt5-connectivity' 'qt5-quickcontrols2' 'qt5-serialport' 'qt5-location')
makedepends=('git')
-provides=("${pkgname%-VCS}")
-conflicts=("${pkgname%-VCS}")
-replaces=()
-backup=()
-options=()
-install=
-source=("git+https://github.com/vedderb/vesc_tool.git")
-noextract=()
-md5sums=('SKIP')
+source=("$pkgname"::"git+https://github.com/vedderb/vesc_tool.git"
+ 'vesc_tool.pro')
+
+sha256sums=('SKIP'
+ 'fb9eb66d9ef00606f61754a7efa8dbab18dff810c674a106e2e770e62899be68')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${srcdir}/${pkgname}"
+ printf "${pkgver}.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build() {
- cd "$srcdir/${pkgname%-git}"
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ cp ${srcdir}/vesc_tool.pro .
+}
- qmake -config release "CONFIG += release_lin build_original"
- make
+build() {
+ cd "${srcdir}/${pkgname}"
+ qmake PREFIX=/usr LIBDIR=/usr/lib
+ make
}
package() {
- cd "$srcdir/${pkgname%-git}"
- mkdir -p $pkgdir/usr/bin/
- cp build/lin/vesc_* $pkgdir/usr/bin/vesc_tool
+ cd "$srcdir/${pkgname}"
+ make INSTALL_ROOT="$pkgdir" install
}
diff --git a/vesc_tool.pro b/vesc_tool.pro
new file mode 100644
index 000000000000..d217912d9a2e
--- /dev/null
+++ b/vesc_tool.pro
@@ -0,0 +1,107 @@
+VT_VERSION = 2.03
+VT_INTRO_VERSION = 1
+VT_IS_TEST_VERSION = 0
+
+TEMPLATE = app
+
+DEFINES += VT_VERSION=$$VT_VERSION
+DEFINES += VT_INTRO_VERSION=$$VT_INTRO_VERSION
+DEFINES += VT_IS_TEST_VERSION=$$VT_IS_TEST_VERSION
+
+CONFIG += c++11
+
+# Debug build (e.g. F5 to reload QML files)
+#DEFINES += DEBUG_BUILD
+
+# Bluetooth available
+DEFINES += HAS_BLUETOOTH
+
+# CAN bus available
+# Adding serialbus to Qt seems to break the serial port on static builds. TODO: Figure out why.
+#DEFINES += HAS_CANBUS
+
+# Positioning
+DEFINES += HAS_POS
+
+DEFINES += HAS_SERIALPORT
+
+QT += core gui
+QT += widgets
+QT += printsupport
+QT += network
+QT += quick
+QT += quickcontrols2
+
+contains(DEFINES, HAS_SERIALPORT) {
+ QT += serialport
+}
+
+contains(DEFINES, HAS_CANBUS) {
+ QT += serialbus
+}
+
+contains(DEFINES, HAS_BLUETOOTH) {
+ QT += bluetooth
+}
+
+contains(DEFINES, HAS_POS) {
+ QT += positioning
+}
+
+
+SOURCES += main.cpp\
+ mainwindow.cpp \
+ packet.cpp \
+ vbytearray.cpp \
+ commands.cpp \
+ configparams.cpp \
+ configparam.cpp \
+ vescinterface.cpp \
+ parametereditor.cpp \
+ digitalfiltering.cpp \
+ setupwizardapp.cpp \
+ setupwizardmotor.cpp \
+ startupwizard.cpp \
+ utility.cpp \
+ tcpserversimple.cpp
+
+HEADERS += mainwindow.h \
+ packet.h \
+ vbytearray.h \
+ commands.h \
+ datatypes.h \
+ configparams.h \
+ configparam.h \
+ vescinterface.h \
+ parametereditor.h \
+ digitalfiltering.h \
+ setupwizardapp.h \
+ setupwizardmotor.h \
+ startupwizard.h \
+ utility.h \
+ tcpserversimple.h
+
+FORMS += mainwindow.ui \
+ parametereditor.ui
+
+contains(DEFINES, HAS_BLUETOOTH) {
+ SOURCES += bleuart.cpp
+ HEADERS += bleuart.h
+}
+
+include(pages/pages.pri)
+include(widgets/widgets.pri)
+include(map/map.pri)
+include(lzokay/lzokay.pri)
+
+RESOURCES += res.qrc
+RESOURCES += res_config.qrc
+RESOURCES += res_original.qrc \
+res_fw_original.qrc
+DEFINES += VER_ORIGINAL
+
+isEmpty(PREFIX) {
+ PREFIX = /usr/local
+}
+target.path = $${PREFIX}/bin
+INSTALLS += target