summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD38
-rwxr-xr-xVIDE.desktop12
-rw-r--r--vide-wrapper2
-rw-r--r--vide.xml48
5 files changed, 138 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2864c32c74cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = vide-bin
+ pkgdesc = A toolkit for the Source engine aimed at aiding mappers and modders alike.
+ pkgver = 0.45a
+ pkgrel = 1
+ url = http://www.riintouge.com/VIDE/
+ arch = x86_64
+ license = unknown
+ makedepends = patchelf
+ depends = icu67
+ depends = qt4
+ depends = lcms2
+ depends = freetype2
+ depends = liblqr
+ depends = glib2
+ depends = fontconfig
+ depends = libxext
+ depends = libxt
+ depends = xz
+ depends = bzip2
+ depends = zlib
+ depends = libtool
+ depends = libx11
+ source = http://www.riintouge.com/archive/VIDE/VIDE_latest_64.tar.gz
+ source = http://www.riintouge.com/archive/VIDE/lib64/libMagick++.so.5
+ source = http://www.riintouge.com/archive/VIDE/lib64/libMagickCore.so.5
+ source = http://www.riintouge.com/archive/VIDE/lib64/libMagickWand.so.5
+ source = vide-wrapper
+ source = VIDE.desktop
+ source = vide.xml
+ sha512sums = 82dc328bca33cdce139131132f18bc2e9a2776af648fcce0850aadb19a02593c906eb6b15b266067e4f184b1c0a76d0f41f7df5bc08e3311988351f4f1425dde
+ sha512sums = a36802b973935ceb372ccb97054fe3b95ed6b403c496601efd22f8f342065838a09263649e699de0dbfd9f94084306f3f17000caf127eaf2ce5d7980580a7def
+ sha512sums = 974a423686c95a10b108466532dfca7aad714bfc39c5dcc5b343bd27ccce0cfc0510aea8af396a1adb2143f5c04e4a78df44d5b150638dc8109d7c6249694a2a
+ sha512sums = 9fd337fd08e0e2c98d21e132b4e5af01c4f21d077b0f39225fe0657b974c7c58f6b194c8e907def127ff84c35c7f1a42e52ac21d83e0d778ce43f4c14638ac0a
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = vide-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4180fb400c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+pkgname=vide-bin
+pkgver=0.45a
+pkgrel=1
+pkgdesc='A toolkit for the Source engine aimed at aiding mappers and modders alike.'
+arch=('x86_64')
+url='http://www.riintouge.com/VIDE/'
+license=('unknown')
+depends=('icu67' 'qt4' 'lcms2' 'freetype2' 'liblqr' 'glib2' 'fontconfig' 'libxext' 'libxt' 'xz' 'bzip2' 'zlib' 'libtool' 'libx11')
+makedepends=('patchelf')
+source=('http://www.riintouge.com/archive/VIDE/VIDE_latest_64.tar.gz'
+ 'http://www.riintouge.com/archive/VIDE/lib64/libMagick++.so.5'
+ 'http://www.riintouge.com/archive/VIDE/lib64/libMagickCore.so.5'
+ 'http://www.riintouge.com/archive/VIDE/lib64/libMagickWand.so.5'
+ 'vide-wrapper'
+ 'VIDE.desktop'
+ 'vide.xml')
+sha512sums=('82dc328bca33cdce139131132f18bc2e9a2776af648fcce0850aadb19a02593c906eb6b15b266067e4f184b1c0a76d0f41f7df5bc08e3311988351f4f1425dde'
+ 'a36802b973935ceb372ccb97054fe3b95ed6b403c496601efd22f8f342065838a09263649e699de0dbfd9f94084306f3f17000caf127eaf2ce5d7980580a7def'
+ '974a423686c95a10b108466532dfca7aad714bfc39c5dcc5b343bd27ccce0cfc0510aea8af396a1adb2143f5c04e4a78df44d5b150638dc8109d7c6249694a2a'
+ '9fd337fd08e0e2c98d21e132b4e5af01c4f21d077b0f39225fe0657b974c7c58f6b194c8e907def127ff84c35c7f1a42e52ac21d83e0d778ce43f4c14638ac0a'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+build() {
+ patchelf --remove-rpath VIDE/VIDE
+}
+
+package() {
+ install -Dm755 vide-wrapper "$pkgdir/usr/bin/VIDE"
+ install -Dm755 VIDE/VIDE "$pkgdir/usr/lib/vide/VIDE"
+ install -Dm755 -t "$pkgdir/usr/lib/vide/" VIDE/lib/libSingleApplication.so.1 libMagick++.so.5 libMagickCore.so.5 libMagickWand.so.5
+ install -Dm644 VIDE/noitazilait.ini "$pkgdir/usr/lib/vide/noitazilait.ini"
+
+ install -Dm755 VIDE.desktop "$pkgdir/usr/share/applications/VIDE.desktop"
+ install -Dm644 vide.xml "$pkgdir/usr/share/mime/packages/vide.xml"
+ install -Dm644 VIDE/deploy/multi_manager_icon_48.png "$pkgdir/usr/share/pixmaps/multi_manager_icon_48.png"
+}
diff --git a/VIDE.desktop b/VIDE.desktop
new file mode 100755
index 000000000000..8bb97a3a0310
--- /dev/null
+++ b/VIDE.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=VIDE
+GenericName=Source Engine Toolkit
+Comment=Valve Interactive Development Environment
+Icon=/usr/share/pixmaps/multi_manager_icon_48.png
+Categories=Development;
+Terminal=false
+StartupNotify=false
+Exec=/usr/bin/VIDE %f
+MimeType=application/x-bsp;application/x-gcf;application/x-ncf;application/x-pcf;application/x-vpk;image/x-vtf;text/x-fgd;text/x-vbsp;text/x-vmt;
diff --git a/vide-wrapper b/vide-wrapper
new file mode 100644
index 000000000000..39eb523f0337
--- /dev/null
+++ b/vide-wrapper
@@ -0,0 +1,2 @@
+#!/usr/bin/sh
+LD_LIBRARY_PATH="/usr/lib/vide:$LD_LIBRARY_PATH" exec /usr/lib/vide/VIDE "$@"
diff --git a/vide.xml b/vide.xml
new file mode 100644
index 000000000000..89580e033a45
--- /dev/null
+++ b/vide.xml
@@ -0,0 +1,48 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/x-bsp">
+ <comment>Valve Binary Source Partition</comment>
+ <icon name="application-x-bsp"/>
+ <glob pattern="*.bsp"/>
+ </mime-type>
+ <mime-type type="application/x-gcf">
+ <comment>Valve Game Cache File</comment>
+ <icon name="application-x-gcf"/>
+ <glob pattern="*.gcf"/>
+ </mime-type>
+ <mime-type type="application/x-ncf">
+ <comment>Valve No Cache File</comment>
+ <icon name="application-x-ncf"/>
+ <glob pattern="*.ncf"/>
+ </mime-type>
+ <mime-type type="application/x-pcf">
+ <comment>Valve Particle Cache File</comment>
+ <icon name="application-x-pcf"/>
+ <glob pattern="*.pcf"/>
+ </mime-type>
+ <mime-type type="application/x-vpk">
+ <comment>Valve Package</comment>
+ <icon name="application-x-vpk"/>
+ <glob pattern="*.vpk"/>
+ </mime-type>
+ <mime-type type="image/x-vtf">
+ <comment>Valve Texture File</comment>
+ <icon name="image-x-vtf"/>
+ <glob pattern="*.vtf"/>
+ </mime-type>
+ <mime-type type="text/x-fgd">
+ <comment>Valve Forge Game Data</comment>
+ <icon name="text-x-fgd"/>
+ <glob pattern="*.fgd"/>
+ </mime-type>
+ <mime-type type="text/x-vbsp">
+ <comment>Valve Detail Sprite Description</comment>
+ <icon name="text-x-vbsp"/>
+ <glob pattern="*.vbsp"/>
+ </mime-type>
+ <mime-type type="text/x-vmt">
+ <comment>Valve Material Type</comment>
+ <icon name="text-x-vmt"/>
+ <glob pattern="*.vmt"/>
+ </mime-type>
+</mime-info>