summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed02face5e2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = vigiland-git
+ pkgdesc = Inhibit idle behaviour of a Wayland compositor
+ pkgver = r11.6b84e1a
+ pkgrel = 1
+ url = https://github.com/Jappie3/vigiland
+ arch = x86_64
+ license = AGPL3
+ makedepends = cargo
+ makedepends = git
+ depends = gcc-libs
+ depends = glibc
+ depends = wayland
+ depends = wayland-protocols
+ provides = vigiland
+ conflicts = vigiland
+ options = !debug
+ source = vigiland::git+https://github.com/Jappie3/vigiland
+ sha256sums = SKIP
+
+pkgname = vigiland-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..82e02bb78e40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: U.G. Kulothungan <kulothunganug at gmail dot com>
+
+_pkgname="vigiland"
+pkgname="$_pkgname-git"
+pkgver=r11.6b84e1a
+pkgrel=1
+pkgdesc="Inhibit idle behaviour of a Wayland compositor"
+arch=(x86_64)
+url="https://github.com/Jappie3/$_pkgname"
+license=(AGPL3)
+depends=(gcc-libs glibc wayland wayland-protocols)
+makedepends=(cargo git)
+conflicts=("$_pkgname")
+provides=("$_pkgname")
+options=(!debug)
+source=("$_pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $_pkgname
+ cargo fetch --locked
+}
+
+build() {
+ cd $_pkgname
+ cargo build --locked --release
+}
+
+package() {
+ cd $_pkgname
+ install -vDm755 target/release/$_pkgname -t "$pkgdir/usr/bin/"
+ install -vDm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+}
+