summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
-rw-r--r--install27
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d41185886f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Jan 25 12:42:44 UTC 2016
+pkgbase = vim-ack
+ pkgdesc = This plugin was designed as a Vim frontend for the Perl module App::Ack
+ pkgver = 1.0.9
+ pkgrel = 1
+ url = http://www.vim.org/scripts/script.php?script_id=2572
+ install = install
+ arch = any
+ license = GPL
+ depends = vim
+ depends = ack
+ source = vim-ack-1.0.9.tar.gz::https://github.com/mileszs/ack.vim/archive/1.0.9.tar.gz
+ md5sums = 2dc52e3eed4c65971dbd65ee1b174533
+
+pkgname = vim-ack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b389f173a9f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: PitBall
+
+pkgname=vim-ack
+pkgver=1.0.9
+pkgrel=1
+pkgdesc='This plugin was designed as a Vim frontend for the Perl module App::Ack'
+arch=('any')
+license=('GPL')
+depends=('vim' 'ack')
+url='http://www.vim.org/scripts/script.php?script_id=2572'
+source=($pkgname-$pkgver.tar.gz::https://github.com/mileszs/ack.vim/archive/$pkgver.tar.gz)
+md5sums=('2dc52e3eed4c65971dbd65ee1b174533')
+install=install
+
+ package() {
+ install -d $pkgdir/usr/share/vim/vimfiles
+ cp -a ack.vim-$pkgver/{autoload,doc,ftplugin,plugin} \
+ $pkgdir/usr/share/vim/vimfiles/
+ }
diff --git a/install b/install
new file mode 100644
index 000000000000..5cc08f99c7a9
--- /dev/null
+++ b/install
@@ -0,0 +1,27 @@
+vimdocinstall() {
+ echo -n " Updating Vim help tags... "
+ /usr/bin/vim --noplugin -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_install() {
+ vimdocinstall
+ echo -e " Sample key-mapping in your vimrc:\n"
+ echo -e "\tnmap <leader>a <Esc>:Ack!>"
+ echo
+
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ vimdocinstall
+}
+
+op=$1
+shift
+
+$op $*