summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..64f155fec437
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vim-assistant
+ pkgdesc = Display the definition of functions, variables, etc. (Tags, PHP/JS/Vim/...)
+ pkgver = 1.5.8
+ pkgrel = 1
+ url = http://www.vim.org/scripts/script.php?script_id=2805
+ arch = any
+ groups = vim-plugins
+ license = unknown
+ depends = vim
+ source = vim-assistant-1.5.8.zip::http://www.vim.org/scripts/download_script.php?src_id=22247
+ md5sums = a12e2cffa436e58f48c12491be32c970
+
+pkgname = vim-assistant
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dfd95d28079d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Packager: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+pkgname=vim-assistant
+pkgver=1.5.8
+_scriptid=22247
+pkgrel=1
+pkgdesc="Display the definition of functions, variables, etc. (Tags, PHP/JS/Vim/...)"
+arch=(any)
+url="http://www.vim.org/scripts/script.php?script_id=2805"
+license=('unknown')
+depends=(vim)
+groups=('vim-plugins')
+source=(${pkgname}-${pkgver}.zip::http://www.vim.org/scripts/download_script.php?src_id=${_scriptid})
+md5sums=('a12e2cffa436e58f48c12491be32c970')
+
+package() {
+ cd "${srcdir}"
+ install -dm755 ${pkgdir}/usr/share/vim/vimfiles/plugin/assistant
+ #unzip ${pkgname}-${pkgver} -d ${srcdir}
+ install -Dm644 ${srcdir}/${pkgname}-master/plugin/assistant.vim ${pkgdir}/usr/share/vim/vimfiles/plugin/
+ install -Dm644 ${srcdir}/${pkgname}-master/plugin/assistant/* ${pkgdir}/usr/share/vim/vimfiles/plugin/assistant
+}
+