summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
-rw-r--r--license.txt8
-rw-r--r--vimdoc.install19
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5fb7b5d12109
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vim-codepad
+ pkgdesc = Post the contents of your current buffer to the pastebin service at codepad.org
+ pkgver = 1.4
+ pkgrel = 1
+ url = http://www.vim.org/scripts/script.php?script_id=2298
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = custom
+ depends = gvim
+ source = vim-codepad::http://www.vim.org/scripts/download_script.php?src_id=13438
+ source = license.txt
+ md5sums = a08286132612828b01d5257d4a98cc3c
+ md5sums = efbd5986e691ce8c876fb86e8f5961ea
+
+pkgname = vim-codepad
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c4a1a8e5ef9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Eduardo Reveles <me at osiux dot ws>
+pkgname=vim-codepad
+pkgver=1.4
+_scriptid=13438
+pkgrel=1
+pkgdesc="Post the contents of your current buffer to the pastebin service at codepad.org"
+arch=('any')
+url="http://www.vim.org/scripts/script.php?script_id=2298"
+license=('custom')
+depends=(gvim)
+groups=('vim-plugins')
+install=vimdoc.install
+source=(${pkgname}::http://www.vim.org/scripts/download_script.php?src_id=${_scriptid}
+ license.txt)
+md5sums=('a08286132612828b01d5257d4a98cc3c'
+ 'efbd5986e691ce8c876fb86e8f5961ea')
+
+package() {
+ cd "${srcdir}"
+ local vimfiles="${pkgdir}/usr/share/vim/vimfiles"
+ install -Dm0644 vim-codepad "$vimfiles/plugin/codepad.vim"
+ install -Dm0644 license.txt "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+} \ No newline at end of file
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..226f27b5356b
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,8 @@
+Copyright (C) 2002-2007 Yegappan Lakshmanan
+Permission is hereby granted to use and distribute this code,
+with or without modifications, provided that this copyright
+notice is copied with it. Like anything else that's free,
+taglist.vim is provided *as is* and comes with no warranty of any
+kind, either expressed or implied. In no event will the copyright
+holder be liable for any damamges resulting from the use of this
+software.
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..5246e5c21134
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,19 @@
+post_install() {
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}
+
+op=$1
+shift
+
+$op $*