summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD27
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad494efec484
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vim-dockerfile-git
+ pkgdesc = Vim syntax file & snippets for Docker's Dockerfile
+ pkgver = r133.2386923
+ pkgrel = 1
+ url = https://github.com/ekalinin/Dockerfile.vim
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ makedepends = git
+ depends = vim-plugin-runtime
+ source = vim-dockerfile::git+https://github.com/ekalinin/Dockerfile.vim
+ sha256sums = SKIP
+
+pkgname = vim-dockerfile-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fdeea0d36d04
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Whitelist
+!PKGBUILD
+!.SRCINFO
+
+# Blacklist
+*
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc5e92535197
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: lmartinez-mirror
+pkgname=vim-dockerfile-git
+_pkgname=${pkgname%-git}
+pkgver=r133.2386923
+pkgrel=1
+pkgdesc="Vim syntax file & snippets for Docker's Dockerfile"
+arch=('any')
+url="https://github.com/ekalinin/Dockerfile.vim"
+license=('MIT')
+depends=('vim-plugin-runtime')
+groups=('vim-plugins')
+makedepends=('git')
+source=("${_pkgname}::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_pkgname"
+ find ftdetect ftplugin indent snippets syntax -type f \
+ -exec install -Dm644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+