summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rwxr-xr-xPKGBUILD22
-rwxr-xr-xlicense.txt8
-rwxr-xr-xvimdoc.install19
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..44261a4b450f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vim-eclipse
+ pkgdesc = while typing a C function, a prototype is shown (man3 based)
+ pkgver = 1.0.2
+ pkgrel = 3
+ url = http://www.vim.org/scripts/script.php?script_id=1802
+ install = vimdoc.install
+ arch = i686
+ arch = x86_64
+ groups = vim-plugins
+ license = custom
+ depends = vim
+ source = eclipse.vim::http://www.vim.org/scripts/download_script.php?src_id=6890
+ source = license.txt
+ md5sums = e132f1c1487c7bfc2b239ce9d3669b8f
+ md5sums = efbd5986e691ce8c876fb86e8f5961ea
+
+pkgname = vim-eclipse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..bb6050af5b28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+
+pkgname=vim-eclipse
+pkgver=1.0.2
+_scriptid=6890
+pkgrel=3
+pkgdesc="while typing a C function, a prototype is shown (man3 based)"
+arch=("i686" "x86_64")
+url="http://www.vim.org/scripts/script.php?script_id=1802"
+license=('custom')
+depends=(vim)
+groups=('vim-plugins')
+install=vimdoc.install
+source=(eclipse.vim::http://www.vim.org/scripts/download_script.php?src_id=${_scriptid}
+ license.txt)
+md5sums=('e132f1c1487c7bfc2b239ce9d3669b8f'
+ 'efbd5986e691ce8c876fb86e8f5961ea')
+
+package() {
+ install -Dm755 "${srcdir}"/eclipse.vim "${pkgdir}"/usr/share/vim/colors/eclipse.vim
+ install -Dm644 "${srcdir}"/license.txt "${pkgdir}"/usr/share/licenses/${pkgname}/license.txt
+}
diff --git a/license.txt b/license.txt
new file mode 100755
index 000000000000..226f27b5356b
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,8 @@
+Copyright (C) 2002-2007 Yegappan Lakshmanan
+Permission is hereby granted to use and distribute this code,
+with or without modifications, provided that this copyright
+notice is copied with it. Like anything else that's free,
+taglist.vim is provided *as is* and comes with no warranty of any
+kind, either expressed or implied. In no event will the copyright
+holder be liable for any damamges resulting from the use of this
+software.
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100755
index 000000000000..5246e5c21134
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,19 @@
+post_install() {
+ echo -n "Updating vim help tags..."
+ /usr/bin/vim --noplugins -u NONE -U NONE \
+ --cmd ":helptags /usr/share/vim/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done."
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install
+}
+
+op=$1
+shift
+
+$op $*