summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
-rw-r--r--vimdoc.install12
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1655e61e301
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vim-file-templates
+ pkgdesc = File templates for VIM
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://sites.google.com/site/abudden/contents/Vim-Scripts/file-templates
+ install = vimdoc.install
+ arch = any
+ groups = vim-plugins
+ license = custom:vim
+ depends = vim-runtime
+ source = vim-file-templates-1.0.vba::https://sites.google.com/site/abudden/contents/Vim-Scripts/file-templates/file_templates.vba?attredirects=0
+ md5sums = 8c49c07c77f160f30794509025132d03
+
+pkgname = vim-file-templates
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33a20d837518
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# vim:set ts=2 sw=2 et ft=sh tw=100: expandtab
+# Maintainer: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+
+pkgname=vim-file-templates
+pkgver=1.0
+pkgrel=1
+pkgdesc='File templates for VIM'
+arch=('any')
+url='https://sites.google.com/site/abudden/contents/Vim-Scripts/file-templates'
+license=('custom:vim')
+groups=('vim-plugins')
+depends=('vim-runtime')
+source=("${pkgname}-${pkgver}.vba::https://sites.google.com/site/abudden/contents/Vim-Scripts/file-templates/file_templates.vba?attredirects=0")
+install='vimdoc.install'
+
+build() {
+ cd "$srcdir"
+ _vim_dir='usr/share/vim/vimfiles'
+ vim -c "set nomore" -c "UseVimball $srcdir" -c "q" $pkgname-$pkgver.vba
+ install -dm755 $pkgdir/${_vim_dir}
+ tar -c ./ \
+ --exclude $pkgname-$pkgver.vba \
+ --exclude .VimballRecord \
+ | tar -x -C "$pkgdir"/${_vim_dir}
+}
+
+md5sums=('8c49c07c77f160f30794509025132d03')
diff --git a/vimdoc.install b/vimdoc.install
new file mode 100644
index 000000000000..778d02cf0002
--- /dev/null
+++ b/vimdoc.install
@@ -0,0 +1,12 @@
+post_install() {
+ echo "After installation, create the directory ~/.vim/templates and copy into it files from /usr/share/vim/vimfiles/templates/"
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+op=$1
+shift
+
+$op $*