summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa503fd96455..1eafd5a5bba3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = vim-gutentags-git
pkgdesc = A Vim plugin that manages your tag files
pkgver = 1.0.0.r77.g1337b18
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ludovicchabant/vim-gutentags
arch = any
groups = vim-plugins
license = MIT
makedepends = git
depends = vim-plugin-runtime
+ depends = ctags
provides = vim-gutentags
conflicts = vim-gutentags
source = vim-gutentags::git+https://github.com/ludovicchabant/vim-gutentags
diff --git a/PKGBUILD b/PKGBUILD
index 403dcb946017..d0ac3a6720b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=vim-gutentags-git
_pkg="${pkgname%-git}"
pkgver=1.0.0.r77.g1337b18
-pkgrel=2
+pkgrel=3
pkgdesc='A Vim plugin that manages your tag files'
arch=('any')
url='https://github.com/ludovicchabant/vim-gutentags'
license=('MIT')
groups=('vim-plugins')
-depends=('vim-plugin-runtime')
+depends=('vim-plugin-runtime' 'ctags')
makedepends=('git')
provides=("$_pkg")
conflicts=("$_pkg")
@@ -25,5 +25,6 @@ package() {
local dirs=(autoload doc plat/unix plugin res)
cd "$_pkg"
find "${dirs[@]}" -type f -exec install -Dvm644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ chmod 755 "$pkgdir/usr/share/vim/vimfiles/plat/unix/"*.sh
install -Dvm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}