summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD15
3 files changed, 28 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d8988eee82d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = vim-opengl
+ pkgdesc = Vim syntax highlighting for OpenGL, OpenGLES & EGL
+ pkgver = 1.5
+ pkgrel = 1
+ url = http://www.vim.org/scripts/script.php?script_id=752
+ arch = any
+ source = opengl.vim::http://www.vim.org/scripts/download_script.php?src_id=7583
+ sha1sums = 8cf57810d7a307cede2f28780224488bf711091e
+
+pkgname = vim-opengl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ad0c081bae80
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.pkg.*
+*.vim
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d14bd7dce94e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,15 @@
+# Maintainer: Eric Engestrom <aur [at] engestrom [dot] ch>
+
+pkgname=vim-opengl
+pkgver=1.5
+pkgrel=1
+pkgdesc='Vim syntax highlighting for OpenGL, OpenGLES & EGL'
+arch=('any')
+url='http://www.vim.org/scripts/script.php?script_id=752'
+_file='opengl.vim'
+source=("${_file}::http://www.vim.org/scripts/download_script.php?src_id=7583")
+sha1sums=('8cf57810d7a307cede2f28780224488bf711091e')
+
+package() {
+ install -Dm644 "${srcdir}/${_file}" "${pkgdir}"/usr/share/vim/vimfiles/syntax/"${_file}"
+}