summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD11
3 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18ce548fa438..a5e3245c6b99 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vim-plugins-profiler
pkgdesc = Utility to output a sorted list of VIM plugin startup times in millisec.
- pkgver = 1.15
+ pkgver = 1.16
pkgrel = 1
url = https://github.com/bulletmark/vim-plugins-profiler
arch = any
@@ -9,8 +9,9 @@ pkgbase = vim-plugins-profiler
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
- depends = python>=3.5
- source = vim-plugins-profiler-1.15.tar.gz::https://github.com/bulletmark/vim-plugins-profiler/archive/1.15.tar.gz
- md5sums = 57c6fedf1146f8bc1a92c14279d7fa41
+ makedepends = python-setuptools-scm
+ depends = python>=3.6
+ source = vim-plugins-profiler-1.16.tar.gz::https://github.com/bulletmark/vim-plugins-profiler/archive/1.16.tar.gz
+ md5sums = dac3136d5452d3909da3820058368e28
pkgname = vim-plugins-profiler
diff --git a/.gitignore b/.gitignore
index 6dd39bbd03b8..ad6fbda9f142 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
pkg/
src/
*.tar
+*.tar.*
*.[gx]z
diff --git a/PKGBUILD b/PKGBUILD
index 31d82671f23b..578b1dfbac8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=vim-plugins-profiler
-pkgver=1.15
+pkgver=1.16
pkgrel=1
pkgdesc="Utility to output a sorted list of VIM plugin startup times in millisec."
url="https://github.com/bulletmark/$pkgname"
license=(GPL3)
arch=(any)
-depends=("python>=3.5")
-makedepends=(python-setuptools python-build python-installer python-wheel)
+depends=("python>=3.6")
+makedepends=(python-setuptools python-build python-installer
+ python-wheel python-setuptools-scm)
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-md5sums=('57c6fedf1146f8bc1a92c14279d7fa41')
+md5sums=('dac3136d5452d3909da3820058368e28')
build() {
cd "$srcdir/$pkgname-$pkgver"
- python -m build --wheel --no-isolation
+ SETUPTOOLS_SCM_PRETEND_VERSION="$pkgver" python -m build --wheel --no-isolation
}
package() {