summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD34
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3172d92867d1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = vim-spaceduck-git
+ pkgdesc = An intergalatic space theme for Vim
+ pkgver = r22.0d06e20
+ pkgrel = 1
+ url = https://github.com/pineapplegiant/spaceduck
+ arch = any
+ groups = vim-plugins
+ license = MIT
+ makedepends = git
+ depends = vim-plugin-runtime
+ optdepends = vim-polyglot
+ provides = vim-spaceduck
+ provides = vim-airline-spaceduck
+ provides = vim-lightline-spaceduck
+ provides = neovim-lualine-spaceduck
+ conflicts = vim-spaceduck
+ conflicts = vim-airline-spaceduck
+ conflicts = vim-lightline-spaceduck
+ conflicts = neovim-lualine-spaceduck
+ source = vim-spaceduck-git::git+https://github.com/pineapplegiant/spaceduck
+ sha256sums = SKIP
+
+pkgname = vim-spaceduck-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c27977a09093
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+
+pkgname=vim-spaceduck-git
+pkgver=r22.0d06e20
+pkgrel=1
+pkgdesc="An intergalatic space theme for Vim"
+arch=('any')
+url="https://github.com/pineapplegiant/spaceduck"
+license=('MIT')
+groups=('vim-plugins')
+depends=('vim-plugin-runtime')
+optdepends=('vim-polyglot')
+makedepends=('git')
+provides=("${pkgname%-git}" 'vim-airline-spaceduck' 'vim-lightline-spaceduck' 'neovim-lualine-spaceduck')
+conflicts=("${pkgname%-git}" 'vim-airline-spaceduck' 'vim-lightline-spaceduck' 'neovim-lualine-spaceduck')
+source=("$pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ (
+ set -o pipefail
+ git describe --long 2>/dev/null | sed 's/^v//;s/-/.r/;s/-/./' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ cd "$pkgname"
+ find autoload colors lua \
+ -type f -exec install -Dvm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dvm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}