summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
-rw-r--r--vimdoc.install14
4 files changed, 27 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 033afdd29971..2f1cbffc24af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = vim-workspace
- pkgdesc = vim workspace manager plugin for managing groups of files
- pkgver = 1.0b1
- pkgrel = 10
- url = http://www.vim.org/scripts/script.php?script_id=1410
+ pkgdesc = Vim workspace manager plugin for managing groups of files
+ pkgver = 1.8.3
+ pkgrel = 1
+ url = https://github.com/thaerkh/vim-workspace
arch = any
groups = vim-plugins
- license = unknown
- makedepends = unzip
- depends = vim
- source = https://www.vim.org/scripts/download_script.php?src_id=4812
- md5sums = bd6828d19ce7c62aac0afe28b881a8ba
+ license = Apache
+ depends = vim-plugin-runtime
+ source = vim-workspace-1.8.3.tar.gz::https://github.com/thaerkh/vim-workspace/archive/refs/tags/1.8.3.tar.gz
+ sha256sums = fa08cc225ec31973aaf5751bf51eefdfb5edcc379f1d698006af1e68974d4a31
pkgname = vim-workspace
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..73de0d900192
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+*
diff --git a/PKGBUILD b/PKGBUILD
index b06c99cb7fca..a05edf5ca068 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,23 @@
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
# Contributor: Aaron Griffin <aaron@archlinux.org>
-# Maintainer: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=vim-workspace
-pkgver=1.0b1
-_scriptid=4812
-pkgrel=10
-pkgdesc="vim workspace manager plugin for managing groups of files "
+pkgver=1.8.3
+pkgrel=1
+pkgdesc="Vim workspace manager plugin for managing groups of files"
arch=('any')
-url="http://www.vim.org/scripts/script.php?script_id=1410"
-license=('unknown')
-depends=('vim')
-makedepends=('unzip')
+url="https://github.com/thaerkh/vim-workspace"
+license=('Apache')
+depends=('vim-plugin-runtime')
groups=('vim-plugins')
-source=(https://www.vim.org/scripts/download_script.php?src_id=$_scriptid)
-md5sums=('bd6828d19ce7c62aac0afe28b881a8ba')
-
-build() {
- cd ${srcdir}
-
- mv download_script.php?src_id=$_scriptid workspace_1b1.zip
- unzip -qqo workspace_1b1.zip
-}
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('fa08cc225ec31973aaf5751bf51eefdfb5edcc379f1d698006af1e68974d4a31')
package() {
- cd ${srcdir}
-
- installpath="${pkgdir}/usr/share/vim/vimfiles"
-
- install -D -m644 doc/workspace.txt \
- $installpath/doc/workspace.txt
- install -D -m644 plugin/workspace.vim \
- $installpath/plugin/workspace.vim
+ cd "$pkgname-$pkgver"
+ find doc plugin \
+ -type f -exec install -Dvm 644 '{}' "$pkgdir/usr/share/vim/vimfiles/{}" \;
+ install -Dvm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dvm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}
diff --git a/vimdoc.install b/vimdoc.install
deleted file mode 100644
index 4bf6316dd78c..000000000000
--- a/vimdoc.install
+++ /dev/null
@@ -1,14 +0,0 @@
-post_install() {
- echo -n "Updating vim help tags..."
- /usr/bin/vim --noplugins -u NONE -U NONE \
- --cmd ":helptags /usr/share/vim/vimfiles/doc" --cmd ":q" > /dev/null 2>&1
- echo "done."
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install
-}