summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD45
-rw-r--r--code-url-handler.desktop (renamed from visual-studio-code-url-handler.desktop)4
-rw-r--r--code.desktop (renamed from visual-studio-code.desktop)8
-rw-r--r--visual-studio-code-bin.install21
-rw-r--r--visual-studio-code-bin.sh11
6 files changed, 80 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e913349e35fd..243f02fa0362 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = visual-studio-code-bin
pkgdesc = Visual Studio Code (vscode): Editor for building and debugging modern web and cloud applications (official binary version)
- pkgver = 1.60.0
+ pkgver = 1.89.1
pkgrel = 1
url = https://code.visualstudio.com/
+ install = visual-studio-code-bin.install
arch = x86_64
- arch = i686
arch = aarch64
arch = armv7h
license = custom: commercial
@@ -20,24 +20,27 @@ pkgbase = visual-studio-code-bin
depends = lsof
depends = shared-mime-info
depends = xdg-utils
+ depends = alsa-lib
optdepends = glib2: Needed for move to trash functionality
optdepends = libdbusmenu-glib: Needed for KDE global menu
optdepends = org.freedesktop.secrets: Needed for settings sync
+ optdepends = icu69: Needed for live share
provides = code
+ provides = vscode
conflicts = code
- source = visual-studio-code.desktop
- source = visual-studio-code-url-handler.desktop
+ source = code.desktop
+ source = code-url-handler.desktop
source = visual-studio-code-workspace.xml
- sha256sums = 07909803b0ce5e3412a92a2303e546c970ab48db505d6bf25fbd55dbb8466982
- sha256sums = be3d123aacd575d8f836728266eb421ea70399d713d1fc30378dbc5602b519fb
+ source = visual-studio-code-bin.sh
+ sha256sums = b8d55bc61c7c974087930168c2ff93e3ff28cf09e023d02db410d6e5723c361a
+ sha256sums = 2264dd138b77358709aa49fb3a7fe7d1b05b7ab0715760d66958000107bdd3dc
sha256sums = 24ba09a6398c9781ed7cb6f1a9f6f38ec204899ba1f33db92638bf6d3cb0aed6
- source_x86_64 = code_x64_1.60.0.tar.gz::https://update.code.visualstudio.com/1.60.0/linux-x64/stable
- sha256sums_x86_64 = 0cd40e565f75a4887acb7deba75ec99549d31e6d070f7e0f08b0467b8b39893c
- source_i686 = code_ia32_1.60.0.tar.gz::https://update.code.visualstudio.com/latest/linux-ia32/stable
- sha256sums_i686 = 64360439cc2fa596838062f7e6f9757b79d4b775a564f18bad6cbad154bf850c
- source_aarch64 = code_arm64_1.60.0.tar.gz::https://update.code.visualstudio.com/1.60.0/linux-arm64/stable
- sha256sums_aarch64 = 9d91d083a646c91c61da4253cb07ee84e605b28fd863b41395677909cd7ef5ae
- source_armv7h = code_armhf_1.60.0.tar.gz::https://update.code.visualstudio.com/1.60.0/linux-armhf/stable
- sha256sums_armv7h = 0f99a0c5a49554fc72d2d84350ccb236a0d4c4e5a0d5e106b9a7501e3c177718
+ sha256sums = 8257a5ad82fa1f7dec11dfa064217b80df4cfec24f50cec7ca0ad62cf8295bfe
+ source_x86_64 = code_x64_1.89.1.tar.gz::https://update.code.visualstudio.com/1.89.1/linux-x64/stable
+ sha256sums_x86_64 = 5d7bdd5a40f46b06ee2265a2598e3e1c4e53adbe35969f3d9350e66b1e22d0fd
+ source_aarch64 = code_arm64_1.89.1.tar.gz::https://update.code.visualstudio.com/1.89.1/linux-arm64/stable
+ sha256sums_aarch64 = 11bfb95177174980374a9c1e1dfef54433d659319950c90c728b5fd7daff4467
+ source_armv7h = code_armhf_1.89.1.tar.gz::https://update.code.visualstudio.com/1.89.1/linux-armhf/stable
+ sha256sums_armv7h = 7380d315cc0c8316436237b9cb56a1a130b3033a596acae721f78f5757df4107
pkgname = visual-studio-code-bin
diff --git a/PKGBUILD b/PKGBUILD
index ee7bcbdecffd..38b0140e99d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,35 +2,36 @@
pkgname=visual-studio-code-bin
_pkgname=visual-studio-code
-pkgver=1.60.0
+pkgver=1.89.1
pkgrel=1
pkgdesc="Visual Studio Code (vscode): Editor for building and debugging modern web and cloud applications (official binary version)"
-arch=('x86_64' 'i686' 'aarch64' 'armv7h')
+arch=('x86_64' 'aarch64' 'armv7h')
url="https://code.visualstudio.com/"
license=('custom: commercial')
-provides=('code')
+provides=('code' 'vscode')
conflicts=('code')
+install=$pkgname.install
# lsof: needed for terminal splitting, see https://github.com/Microsoft/vscode/issues/62991
# xdg-utils: needed for opening web links with xdg-open
-depends=(libxkbfile gnupg gtk3 libsecret nss gcc-libs libnotify libxss glibc lsof shared-mime-info xdg-utils)
+depends=(libxkbfile gnupg gtk3 libsecret nss gcc-libs libnotify libxss glibc lsof shared-mime-info xdg-utils alsa-lib)
optdepends=('glib2: Needed for move to trash functionality'
'libdbusmenu-glib: Needed for KDE global menu'
- 'org.freedesktop.secrets: Needed for settings sync')
-source=(${_pkgname}.desktop ${_pkgname}-url-handler.desktop ${_pkgname}-workspace.xml)
+ 'org.freedesktop.secrets: Needed for settings sync'
+ # See https://github.com/MicrosoftDocs/live-share/issues/4650
+ 'icu69: Needed for live share' )
+source=(code.desktop code-url-handler.desktop ${_pkgname}-workspace.xml ${_pkgname}-bin.sh)
source_x86_64=(code_x64_${pkgver}.tar.gz::https://update.code.visualstudio.com/${pkgver}/linux-x64/stable)
source_aarch64=(code_arm64_${pkgver}.tar.gz::https://update.code.visualstudio.com/${pkgver}/linux-arm64/stable)
source_armv7h=(code_armhf_${pkgver}.tar.gz::https://update.code.visualstudio.com/${pkgver}/linux-armhf/stable)
-# i686 uses "latest" instead of a specific version as it's not always updated in a timely manner
-source_i686=(code_ia32_${pkgver}.tar.gz::https://update.code.visualstudio.com/latest/linux-ia32/stable)
# This generates cleaner checksums
-sha256sums=('07909803b0ce5e3412a92a2303e546c970ab48db505d6bf25fbd55dbb8466982'
- 'be3d123aacd575d8f836728266eb421ea70399d713d1fc30378dbc5602b519fb'
- '24ba09a6398c9781ed7cb6f1a9f6f38ec204899ba1f33db92638bf6d3cb0aed6')
-sha256sums_x86_64=('0cd40e565f75a4887acb7deba75ec99549d31e6d070f7e0f08b0467b8b39893c')
-sha256sums_i686=('64360439cc2fa596838062f7e6f9757b79d4b775a564f18bad6cbad154bf850c')
-sha256sums_aarch64=('9d91d083a646c91c61da4253cb07ee84e605b28fd863b41395677909cd7ef5ae')
-sha256sums_armv7h=('0f99a0c5a49554fc72d2d84350ccb236a0d4c4e5a0d5e106b9a7501e3c177718')
+sha256sums=('b8d55bc61c7c974087930168c2ff93e3ff28cf09e023d02db410d6e5723c361a'
+ '2264dd138b77358709aa49fb3a7fe7d1b05b7ab0715760d66958000107bdd3dc'
+ '24ba09a6398c9781ed7cb6f1a9f6f38ec204899ba1f33db92638bf6d3cb0aed6'
+ '8257a5ad82fa1f7dec11dfa064217b80df4cfec24f50cec7ca0ad62cf8295bfe')
+sha256sums_x86_64=('5d7bdd5a40f46b06ee2265a2598e3e1c4e53adbe35969f3d9350e66b1e22d0fd')
+sha256sums_aarch64=('11bfb95177174980374a9c1e1dfef54433d659319950c90c728b5fd7daff4467')
+sha256sums_armv7h=('7380d315cc0c8316436237b9cb56a1a130b3033a596acae721f78f5757df4107')
@@ -50,16 +51,20 @@ package() {
install -d "${pkgdir}/opt/${_pkgname}"
install -d "${pkgdir}/usr/bin"
install -d "${pkgdir}/usr/share/applications"
- install -d "${pkgdir}/usr/share/icons"
+ install -d "${pkgdir}/usr/share/icons"
install -d "${pkgdir}/usr/share/mime/packages"
install -m644 "${srcdir}/${_pkg}/resources/app/LICENSE.rtf" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE.rtf"
install -m644 "${srcdir}/${_pkg}/resources/app/resources/linux/code.png" "${pkgdir}/usr/share/icons/${_pkgname}.png"
- install -m644 "${srcdir}/${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
- install -m644 "${srcdir}/${_pkgname}-url-handler.desktop" "${pkgdir}/usr/share/applications/${_pkgname}-url-handler.desktop"
+ install -m644 "${srcdir}/code.desktop" "${pkgdir}/usr/share/applications/code.desktop"
+ install -m644 "${srcdir}/code-url-handler.desktop" "${pkgdir}/usr/share/applications/code-url-handler.desktop"
install -m644 "${srcdir}/${_pkgname}-workspace.xml" "${pkgdir}/usr/share/mime/packages/${pkgname}-workspace.xml"
+ install -Dm 644 "${srcdir}/${_pkg}/resources/completions/bash/code" "${pkgdir}/usr/share/bash-completion/completions/code"
+ install -Dm 644 "${srcdir}/${_pkg}/resources/completions/zsh/_code" "${pkgdir}/usr/share/zsh/site-functions/_code"
- cp -r "${srcdir}/${_pkg}/"* "${pkgdir}/opt/${_pkgname}" -R
- ln -s /opt/${_pkgname}/bin/code "${pkgdir}"/usr/bin/code
+ cp -r "${srcdir}/${_pkg}/"* "${pkgdir}/opt/${_pkgname}"
+
+ # Launcher
+ install -m755 "${srcdir}/${_pkgname}-bin.sh" "${pkgdir}/usr/bin/code"
}
diff --git a/visual-studio-code-url-handler.desktop b/code-url-handler.desktop
index 916ceaa83039..5890a14d22d2 100644
--- a/visual-studio-code-url-handler.desktop
+++ b/code-url-handler.desktop
@@ -2,11 +2,11 @@
Name=Visual Studio Code - URL Handler
Comment=Code Editing. Redefined.
GenericName=Text Editor
-Exec=/opt/visual-studio-code/code --no-sandbox --open-url %U
+Exec=/usr/bin/code --open-url %U
Icon=visual-studio-code
Type=Application
NoDisplay=true
StartupNotify=true
-Categories=Utility;TextEditor;Development;IDE;
+Categories=TextEditor;Development;IDE;
MimeType=x-scheme-handler/vscode;
Keywords=vscode;
diff --git a/visual-studio-code.desktop b/code.desktop
index 2d4f180329e5..b2b2a2824081 100644
--- a/visual-studio-code.desktop
+++ b/code.desktop
@@ -2,17 +2,17 @@
Name=Visual Studio Code
Comment=Code Editing. Refined.
GenericName=Text Editor
-Exec=/opt/visual-studio-code/code --no-sandbox --unity-launch %F
+Exec=/usr/bin/code %F
Icon=visual-studio-code
Type=Application
StartupNotify=false
StartupWMClass=Code
-Categories=Utility;TextEditor;Development;IDE;
-MimeType=text/plain;inode/directory;application/x-visual-studio-code-workspace;
+Categories=TextEditor;Development;IDE;
+MimeType=text/plain;inode/directory;application/x-code-workspace;
Actions=new-empty-window;
Keywords=vscode;
[Desktop Action new-empty-window]
Name=New Empty Window
-Exec=/opt/visual-studio-code/code --no-sandbox --new-window %F
+Exec=/usr/bin/code --new-window %F
Icon=visual-studio-code
diff --git a/visual-studio-code-bin.install b/visual-studio-code-bin.install
new file mode 100644
index 000000000000..f7b11b341cd2
--- /dev/null
+++ b/visual-studio-code-bin.install
@@ -0,0 +1,21 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ note "Custom flags should be put directly in: ~/.config/code-flags.conf"
+}
+
+post_upgrade() {
+ post_install
+} \ No newline at end of file
diff --git a/visual-studio-code-bin.sh b/visual-studio-code-bin.sh
new file mode 100644
index 000000000000..7650d63aad12
--- /dev/null
+++ b/visual-studio-code-bin.sh
@@ -0,0 +1,11 @@
+#!/bin/bash
+
+XDG_CONFIG_HOME=${XDG_CONFIG_HOME:-~/.config}
+
+# Allow users to override command-line options
+if [[ -f $XDG_CONFIG_HOME/code-flags.conf ]]; then
+ CODE_USER_FLAGS="$(sed 's/#.*//' $XDG_CONFIG_HOME/code-flags.conf | tr '\n' ' ')"
+fi
+
+# Launch
+exec /opt/visual-studio-code/bin/code "$@" $CODE_USER_FLAGS